Cannot format 64gb microSD - Warranty issue?

I’ve posted before here but didn’t have much luck, see :

I believe the card to be a SDSDQY-064G-U46A. Its the grey & red ultra micro SD 64gb.

This card has seemingly never worked properly, but it would appear it isn’t uncommon. In the end I gave up and have been copying stuff via wi-fi to the phone but this is not ideal when I want to copy ~40Gb of files.

I’m in the same situation again - wanted to copy some files to the card but it just dismounts, again I’ve tried:

Using a card reader

Using the SD adapter in the card reader

Plugging in the phone

Using the SD adapter directly in my laptop.

machines are win7 64bit and win8.1, no matter what I can’t get to write anything to the card. If I plug it in and try and copy files the drive disappears, next time you plug it in it’ll say it needs to be scanned - it then works ok and you can unmount and remove and plug in back in with no problem.

It has escalated now to the point that the phone and both windows machines are unable to format the card, it just says it failed, so the card is totally unusable.

Are there any low level check/fix programs I can run to repair the card ?

I believe it has a 5 year warranty, should I be calling sandisk ?

Hello first of all,

I think that if the microSD card cant be recognized or used by all of your pcs as you say then i think that the card is broken and you should call sanDisk to check if the card is an authentic one and if yes to see if the warranty is still usable for a replacement.

I hope that my answer was usefull to you but of courxe i will continue looking for the best solution.