64Gb MicroSD

I’ve bought a 64Gb microSD card to use in my Galaxy S3. I think its a  SDSDQY-064G-U46A.

Formatted as exFAT.

When in the phone it works fine, the problem comes when trying to use the card with windows.

I have tried both a desktop and my laptop, both run win7 64bit.

I’ve tried accessing the card by:

plugging in the phone

using a belkin card reader

using the sandisk sd card converter directly in the laptop

using the sd card convertor in the belkin card reader

Basically its very unstable, its very slow to access or copy files to (often takes a minute to in windows explorer). I’ve used a number of different applications to copy music files to the card, quite often the programs hang or fail. 

I’ve seen it do really odd things, for example it will report the correct amount of space free/used but when borwsing a directory it doesn’t show all the files/folders. I’ve deleted all viewable files/folders and disconnected the card, then reconnected and other files that were there all along will appear.

Sometimes it just disappears from windows explorer, regardless of if its shown as an MTP device or mass storage.

I’ve formatted using the PCs and the phone, it makes no difference.

When accessed via the phone its an MTP device, when in the card readers its mass storage, it just doesn’t seem to play nicely with windows at all.

I’m not the only one to have problems either: http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=66514

Is there anything I can do too make this thing work ? is it faulty ? Is there any way to check ?