Galaxy S3 and SanDisk 64 micro SD


I’ve bought a Sandisk 64 microSD card last January to use with my galaxy s3 GT-I9300. It worked without problems, then it unmounted once, maybe twice, but I didn’t pay much attention to it.

Till about three days ago, when it stopped working. The phone would say it was preparing the SD card, then, after several minutes, it’d say I could remove it safely. Same problem when I’ve tried it on my husband’s s3.

My laptop could read the card with the card adapter that came with the card when I’ve bought it (Amazon). I’ve noticed it had only 4 gigas free and deleted an extra 4 gb using the laptop (windows7). I’ve also used chkdsk with /f. When I put the card on the phone again, it worked.

Now, I was happy with the card before, but now I wonder if the problem will happen again. I wanna be able to trust the card, as I travel a lot and I do need a lot of memory during these trips. I have backup, but I need the card working properly.

Does anyone have experience with this problem? Could it be the problem was just that the card was too full (only 4 gb free of 64 gb the card has)? If that is the case, what is the threshold of content (in gb) to be sure the card works properly?

I have many files, but none of them exceeds 1gb in size. Also, my card is formatted exFAT. Could this be the problem?

The reason I’m worried is that when I travel, I don’t have a computer available. That was the case now. Luckily, when the card failed, I was only two days away from home and a computer, but I often travel for 7 weeks. What if the card fails again?

I have other cards (less capacity), different brands and I’ve tested all of them on my S3. No problems, so, I’m assuming my S3 isn’t the source of the problem.

Thank you for any input.


If you read about samsung phones in the internet they had and some still have issues with sandisk micro sd cards but if you buy a newest one they should work fine, because before a year or a bit less they had compatibility issues only with samsung phones and there is nothing you can do about it but to ask for a replacement from sandisk and they probably wont have a problem to replace you the cards.

I hope i could help a bit with my answer.


I faced the same issue with my samsung s3 and micro sd (ultra) memory card. Did you find any cure for this? Thankfully i could recover them from my laptop but the card is not reading on my phone. Please let me know if there is any possible way to make it work again.

The phone says " checking for errors" and then later on says " you can safely remove the card"

This is really frustrating :angry:

Not only with Samsung…
Sony’s forum is literally full with topics about these cards failing. They had in common: the lifespan of the card until it failed. Also when it was bought and the period it failed <— same batch?
And I’m certain Samsung and Sony aren’t the only ones.

Best contact support and send the card RMA.
you get refunded or a new replacement.