I can't put music on my Sansa

I have 96 songs on my MP3 right now. I dragged them over from my computer, they are all MP3 format. Since then I have tried to rip music from my cd’s to put on my Sansa and they won’t go on. I have also tried to download more songs which are in MP3 format and put them on and the Sansa won’t read them. When it is connected to my computer it shows up as having the songs on it and they will play through the computer, but when it is not plugged into the computer they won’t play. The songs are also not taking up any space on the Sansa.

I have the same problem.  The files are on the device.  I can read the device from the computer and the files are listed and play fine.  Disconnect from the computer and the songs don’t even show up on the device.  WTH???  They are all .mp3 files. 

I also couldn’t drag and drop into the Sansa Express.  I used Windows Media Player to “sync” the files to the device.

What’s going on???

I used to get all sorts of problems when I first got my SE.


Try these:


1. Back up all your music files.

2. Make sure you have latest Windows driver installed in your PC?

    Register with Microsoft and Windows Update program will then do this automatically.

3. Install the latest firmware for the SE.

4. Format the SE and the card using the format facility built into the SE.

5. SE do not like loading up huge number of files at a time. Load one album/folder at a time.

6. Be patient! Watch the OLED and make sure that each operation is complete before pressing the buttons again.



Message Edited by BlueMax on 01-18-2008 04:52 PM

I figured out what the problem was with mine. I had to go back to the menu, selct music, and then select play all. For some reason it won’t acknowledge the music files until you do this.