I can't get my pc to recognize my new Sansa Clip

I really need some help. I have formated this thing 5 times. I have performed the hold lock & pressing & holding down the middle button while inserting usb into computer. I have tried this on XP & Vista OS. I installed the software disk but I still can get either pc to see the device. Does any one have a copy of the software listed online. The web site doesn’t have the installation driver. Please Please help me. I am about ready to return it to Best Buy.

I have followed everyone’s advice. Cansomeone advise4 me on how to get my pc to see the Sansa clip when I plug in the USB cable?

http://www.sandisk.com/Retail/Default.aspx?CatID=1376

here is the link for the sansa updater. 

Ok…here is something you might want to do…I know you already formatted your device a zillion times already but please do it one more time using the Format option under Settings menu in your device…then restart your computer…then plug in your computer again after restarting to see if it recognizes now…if not…here is one thing you could do…go to this link

http://www.nirsoft.net/utils/usb_devices_view.html

download the USBDeView software and see if the registry has the player in there…select it and delete it and then plug in your PC again to see if it will re-register the device and works…hope this will help.

I did this & it still doesn’t see the device.

So you use the USBDeView to delete your player from registry and it still did not work…have you tried uninstall your WMP and reinstalled it again?  MTP database might be corrupted…or try reassign your device as a different drive, etc.

Can you post the original installation software that came with the device. Maybe my cd was corrupt.

How do I reassign the drive when I can’t even see it

My CD only has the installation for the Rhapsody application and that’s it so unless you want Rhapsody application installed on your PC.  Besides that I do not see anything in the CD that would help though.  My best suggestion is to uninstalled the WMP and reinstall it again…Some posts in the past said that doing this fixes the problem though.

So the doesn’t contain an installation file. Is it a plug & play device or does WMP control the functionality?

It should be a plug-n-play device but probably has some dependency on WMP due to MTP mode.

How do i make sure it is in that mode.

By default, it’s always in that mode unless your system does not support MTP, then it will go to MSC mode.  Also, if you have the latest firmware, you can set so that it will stay in that mode under Settings >> USB mode

I can’t even see the device to install the latest firmwar on it. This should not be this hard, I should be able to just plug it in & it should work. I am seriously thinking about exchaning it for something else.

I guess I’m out of idea of helping you there too unless I can be there to debug it…well hopefully you have better luck with different device then :slight_smile: GL

Try different USB port and also try pushing the cable in hard enough to get connection between device and the cable.  Sometimes, loosely attached cable might not provide you the connection.

My doesn’t recognize too, it was like when I plugged in at first, it ask to check online or choose whatever.  I opened my WMP11, it doesn’t recognize anything at all please help, also in My computer.

My Sansa e200 series, it does works.

I couldn’t get mine to either.  After hours and hours, I finally figured it out.  I hope this works for you too.  I found that the quick start guide said next to nothing, so I downloaded the full users guide.  I read that you need to have Windows XP SP2 and Windows Media Player v10 or higher.  I had XP, but not all the updates nor was I running v10.  After downloading all the Windows updates I was missing, my PC now recognizes the Sansa Clip.  Good luck!

My XP computer was doing the same thing.

I downloaded WMP11, and then it had no problems recognizing the clip.

Vista, WMP11, try push center button in hold mode, but it stills nothing recognize mine. I cannot even see my device, so I can update firmware, I am really have no idea what to do.

PLEASE HELP

Did you try formatting your player?  It has a format option under the main menu.

Try formatting it, then restart your computer, then start WMP11, then plug in your player.

Message Edited by Deebell on 12-27-2007 06:57 AM

Thanks for your help, I am really appreciated.

Unfortunately for me, my Vista Business, WMP11 doesn’t work at all, but when I try with another XP SP2 with WMP11, it works and also recognize immediately.