I can NOT update either way.


I’ve had my Sansa Clip+ for a few years now but I’ve never done any updates since I bought it. So today I decided to try and update the firmware but I couldn’t. Firts I tried using the Sansa Firmware updater but that failed (that last part “launching sansa dispatcher” -failed). Then I tried the manual update but that didn’t work either. The zip file that I get doesn’t open (windows can not open file).

So, I have no idea what the problem is. I think I should just forget about this whole update thing because I think a couple of years ago when I tried to update I had the same problem.

Other than this frustrating update problem, I think this player is the best and the greatest and puts all the rest to shame with all the extras that come with it. To me it’s like a best friend that I never go anywhere without.

To use the firmware file, you need to unzip/extract it from the downloaded zipped firmware file first.  Are you doing that? 

More recent versions of Windows include an unzipping utility and will offer to unzip as an option when you select or click/double-click on the file.  Sometimes, though, with earlier Windows versions, you need to add an unzip utility, such as 7-Zip (freeware), and then unzip using the utility.  http://7-zip.org/ 

1 Like

Thanks for the reply. I just figured it out. I wasn’t paying attention to the “drag the file to the root…”. I thought it was like the regular files where you double click to open.  This one is done by dragging…  Anyway, I don’t see anything different so far but at least it’s still working.