Can't update firmware

Hi,

I just got a Sansa Clip Zip and I tried updating the firmware. However, it doesn’t succeed and I get the following message;

        The following failure occurred:

    Failed to download the selected files.

             Please try again later.

I’ve tried over and over, but it never works.

Tim

  1. Don’t use the Updater.
  2. Are you getting the right firmware veriosn for your player? Clip Zip Firmware 01.01.18
  3. Are you un-zipping the file before dragging the contents over to your player?

I was using the updater. I then did it manually from the link you provided and it worked fine.

Thanks,

Tim

Perhaps your A/V software or firewall was preventing connection with the Updater server or downloading of the firmware. It wouldn’t be the first time I’ve heard that.

Glad you got it sorted out. You’re better off w/o the Updater software on your computer anyway; it’s a resource hog and little more than nag-ware.

Don’t know if this helps but I had a problem also and then switched factory settings from Rest of World to North America and next time I tunred on my computer was able to update the firmware. 

If you were a teardrop;In my eye, url=[http://asianescortedmonton.com]Edmonton Escort[/url]
For fear of losing you,I would never cry url=[http://asianescortedmonton.com],Edmonton Escorts[/url]
And if the golden sun,Should cease to shine its light, url=[http://asianescortedmonton.com]Edmonton Asian Escort[/url]
Just one smile from you,Would make my whole world bright url=[http://asianescortedmonton.com]Edmonton Asian Escorts[/url]