How do I set the clock?

I just bought a Sansa Clip, and the clock is a week slow.

How do I set it? The Sansa e200 had a setting for the

clock, but I cannot find one on the Sansa Clip.

I tried running the Sansa Updater, and a WMP sync, but neither set the clock.

Where are you reading the clock?  The Clip uses a “secure clock” for WMDRM transfers that can be synchronized with Windows Media Player via a pop up screen.

Typically, formatting the device and setting up with WiMP will synchronize the clock.

If you are running Rhapsody, the secure clock can be manually synchronized via the “sources” pane if you hold [Ctrl][Shift] and right click on the device.  Select Reset Secure Clock from the drop down menu.

Bob  :smileyvery-happy:

I am not running Rhapsody. WiMP did once try to set the clock with a

time from the internet, but I was not connected to the internet at the

time, and I cannot persuade WiMP to try again.

I get the wrong clock times when I extract a recording.

this is from my other post from a different thread try it though

This might work I was having a problem with my sansa clip 2gb displaying the correct time when syncing files, the files’ modified date was wrong. I called the tech support line they told me to do the following: “turn off the player then flip the button on the side to lock position where it is showing orange, then press and hold the center button on the player and connect it to the pc wait until its installed then go to my computer and right click the player and choose format.” this should solve your problem it displays the correct time in the files i transfer now so you could try it. hope this helps


1 more note on this it seems the method I posted forces the player to reset in msc mode and sets the clock make sure that you set the mp3 player in settings under usb mode to “msc” not “auto” afterwards and it works fine


Message Edited by icerage7 on 06-19-2008 02:40 PM

I had the same problem with my view.

For WMP 11=

Click on the sync tab

click on it again

click more options…

click on the privacy tab

if the box beside ‘set clock on devices automatically’ is checked, uncheck it

unplug your device and plug it back in

when it says that some protected media requires you to set your clock, click yes

-and make sure you have internet

Message Edited by warrenzo on 07-03-2008 06:31 PM