Can't sync DRM-protected WMA files

When I tried to sync DRM-protected WMA files with Sansa Clip, Windows Media Player said “Not Supported by Device”. I got errors with other audio sync software too. I purchased my 2GB Clip at BestBuy.

WMP11 says, “It is not possible to obtain device’s certificate.”

Have you called Tech Support, I called and they were testing to get an answer but they had PC issues getting the drm license so they couldn’t properly test.  I don’t have time but I would recommend trying to call and provide feedback here if they come up with a solution.


hmmm…I’ve seen this. I’m sure this is fixed, but there may be some units that show this problem when first used. Here is a solution…

Problem: Sansa Clip Devices will not transfer Subscription content correctly from Rhapsody or other Services.  The error “A problem has been encountered in obtaining the devices certificate” may appear in Rhapsody. The device has an invalid DRM license store format

Resolution:  To correct the problem a “Hard Device Format” is required. 


Back up any content present on the device.  The following steps will cause the device to reformat.

1)      Disconnect the Device from the computer. 

2)      Power on the device.

3)      Select the “Home” button and pressing down arrow, navigate to the “Settings” Screen. 

4)      Press the center button. 

5)      Press down arrow and select/ Highlight “Format”. 

6)      Press center button. 

7)      On Format confirmation screen select “Yes”.

The device will perform a Format operation.

Reconnect the device to the Rhapsody (or other)  Music service.

The subscription tracks will now transfer correctly.

format the device using WMP10 or WMP11

Tried this already, it did not work…any other ideas, I am open to testing them as well.

That works. Thank you!

try this update, i had the same issue but had it resolved after calling

Tried this and no love…nobody can seem to help.  Does anyone else have Overdrive or NetLibrary files on their Clip?

It worked for me after I did “format” on Clip. I can play overdrive files.

Try MSC format  .  unplug the device.

Set the hold switch on,

press and hold center button and connect to the PC

In windows explorer, format the device as FAT.

unplug the device

Use the devices format option  from Settings menu again.

power cycle and connect to the PC

Glad to hear you have it working.  Are your Overdrive files by any chance over an hour long.  Do you have any problems with the time display not showing hours correctly?  Just curious.  I seem to be jinxed with this device but I love the form factor.


Yes, those overdrive files are over an hour long each. The display was fine. However the fast forwarding and rewinding are problematic. I reported this to Sansa.

I finally got it working.  It was a group membership issue.  I had to take myself out of the Guest and Domain Guest group and make sure was Admin on my local machine for it work. 

I am surprised the time display was accurate.  I am getting 0:00:00 with my Overdrive files still and it won’t increment the hour until you reach the 10 hour mark.  As noted in my other post at 1 hour, 2 hour, 3 hour, etc and 30 minutes the time display reads 0:30:00. 

Can you confirm that your hours are incrementing properly?  What is the problem you are having with FF and RW? 

Also what firmware version are you on?  Just curious as the time thing is a real annoyance for me.

Thanks in advance for any answers you can provide.


My time display is working fine. But I have only files with an hour+ long. The fast forwarding/rewinding on big files (over one hour) is erratic. After FF accelerates, when you release the button it skips to the next file instead of stops FF.

Firmware v01.01.11A. What is yours?

I had this same problem when I tried to load an audiobook from Recorded books (It was playing on my previous Sandisk till I killed it).  I picked the Clip b/c it was one of the 2 products that support audio books.

What is the suggestion besides calling tech support?

I finally got my audiobook to download - but it will only play up to one hour and then it resets - how do I get it to load under “Audiobook”?  Any suggestions?

Does it really reload (go back to the beginning) or just the hour doesn’t increment but keeps playing fine.  My files play fine and keep going but the hour display just doesn’t change as I described earlier and in another thread.

I goes to the beginning of the next file. Only happen if I fastforward for a long time.

I have v01.01.11A also but hours don’t increment, can you post a digital picture of the time over one hour showing 01:01:00 at one hour and one minute so I can use it in conversation with Sandisk about the problem.