Problem Clip

4g Clip posts following message “Synchronize to continue our music subscription” and freezes.  Any ideas?

The “Synchronize To Continue Music Subscription” message was chosen as the most common DRM error flag.

This message can refer to several different DRM (Digital Rights Media) issues, most easily repaired by resynchronizing your Sansa with the client that transferred the DRM media originally, be it Napster, Rhapsody, Overdrive, Audible, etc.

The DRM pipeline is handled virtually by Windows Media Player, which passes the license data along with protected content.  If you do not have DRM media, WiMP might have made some protected content just for your enjoyment.  It likes to do that.

Look in your “rip” settings, especially if you have selected windows media audio (wma) as your format.  BE SURE to uncheck copy protection in those rip settings, and then retransfer your music file.

Hey, I interchangeably use WMA and MP3, and both formats will work just fine.  WMA compresses a wee bit more efficiently than MP3.  I find 160kb/s wma pretty darn close to 192kb/s MP3, but there’s no way I’ll jump on the happy Microsoft hay wagon and proclaim 64 equal to 128, that’s just silly.

If your files were transferred with Rhapsody / Napster, simply retransfer or allow the client to reread your Sansa, and update the licenses.

Let us know where your music came from, and we can pin the issue down.

Bob  :smileyvery-happy:

All downloads are audio books using WMA.

Okeay then, windows media audio can have copy protection enabled.  Did you rip the books from a CD?  If this is the case, copy protection may be the issue.

Where were the audiobooks from?  If they’re from a service like NetLibrary or Overdrive, you’ll need to retransfer them.

Overdrive Media is transferred using the Media Console.

Bob  :stuck_out_tongue:


All of these were downloaded using OverDrive thru Library.  If I delete these items would this solve the problem?

Yes, delete the files and retransfer them to the Sansa using the Overdrive Media Console.  The Sansa must be in MTP mode, and your coputer needs to have Windows Media Player 10 or 11 installed for the DRM transfers (secure WMA).

This way, the Media Console will transfer the licenses over with your books, and they will play normally.

Bob  :smileyvery-happy:

Thanks, Bob, I’ll give this a try.

I have gone from loving my clip to being increasingly frustrated with it. I primarily use it to download audiobooks. I have never downloaded or used any software like Rhapsody. I have only ever used music I have ripped from my own cds on my own pc or books l have downloaded with overdrive from the library. Now I can play either none of the books I have downloaded from the library or only the first 2 segments at which point it will not play any of the rest of them but prompts me to sync to reset my subscription or most recently transfer title using audiobook software.

I have had a 2GB clip for 18 months now. For 16 months no problems. I download lots of books from the library using overdrive and have played them with no issues. Over the last couple of months everything prompted me to download new versions of things from Overdrive software to clip firmware to internet explorer. Soon after doing all this I tried downloading a new book - no luck my clip was no longer recognized. For the next month I was able to listen to books already on the clip but not download anything else. I finally decided to do something about this and have tried pretty much every fix I could find with none of them working - here are most of the things I do know:

-I can sync to my pc - windows xp

-I have the firmware updater and on my clip it says that I have the firmware V01.01.32A

-My computer will recognize the clip as a MSC by simply plugging it in. I can force it in MTP to hook up - lock the power and hold down center button. But it won’t recognize it a second time with out doing it again.

-I have done the windows media player security upgrade in overdrive.

-I have reformatted several times with the clip in both MTP and MSC and on the computer with the clip in both settings. But all times I continue to have the error message that I need to sync or transfer title

-I have gone into WMP11 and gone to Sync>more options > privacy > and made sure that “download usage rights automatically when I play or sync a file” is checked and it still won’t let me listen once I download book fresh to overdrive and sync to clip.

-In both WMP11 and overdrives the properties say that they audiobooks are authorized to be synced to a device. Once I sync it the properties for the audiobook on the device say “protected content”

Can someone help me please!!!


Your Clip needs to be in MTP mode for the license to transfer with your book.  The method you listed above (Hold/Center Button) will manually force MSC.

On the Clip, go to Settings > USB Mode > MTP to hold the device in MTP mode.  See if the device is recognized as an MTP device.

Bob  :smileyvery-happy:

I just did that and no my PC does not recognize the clip. It does not show up in any way as a drive or a device on “My computer”

Hey there.  With the Clip connected in MTP mode, open the Device Manager.

Right click on My Computer > Device manager.

Look for the wee yellow triangle of doom under Portable Devices.  Right click on the Clip there, selecting uninstall.  Then disconnect, reboot the computer, and let it stabilize.  Then plug in your Clip.  With a little luck, you’ll see “MTP device recognized” pop up when it’s plugged in.

Bob  :stuck_out_tongue:

Hi Bob - you rock!!! Big aloha from a happy gal in Hawaii!!!

I found the yellow circle w/ exclamation point - followed your instructions and was able to get it hooked up in MTP. I restarted my computer, reformated my clip during that time and I just successfully downloaded an audiobook from WMP11 to my clip with no security notices popping up.

Thank you for being such an excellent resource!!

Outstanding!  Can you just feel the groovy?

Bob  :smileyvery-happy: 

Bob, Very good advice.  Using MTP instead of MSC fixed the problem immediately.  Thank you.