I have a Sansa m250. I had loaded some songs on it via WMP but then needed to add some more. I had 2 playlists on WMP; I merged them into one and tried to sync them to the Sansa but there seems to be a communication problem.

WMP says the sync is complete and shows the 75 songs on my Sansa and that the songs are “already on device” but the Sansa itself says there’s nothing there; no songs, no playlist, nothing. It also says that 1.8g has been used, but the Sansa says there’s nothing in my entire Music “section” on the player itself. What’s strange is that under “sync results”, for the Sansa, WMP says the songs are “already on device” but when I scroll down the list to “songs” or “playlist” or “artist” (etc) - they’re all blank. So WMP says the sync is complete and the songs are “already on device” but they’re NOT!

Sansa’s website says to go into “my computer” and find the internal memory, but when I connect the Sansa and go to its USB port, there is no “internal memory” folder or file!

There is a folder under “system” for “data” (with “dat” files) and also a folder “WMDRMPD” and that folder has a file called “store.hds” but I can’t open that.

Can anyone help me? I just want to get my songs onto my Sansa!

Have you tried format it?

I got it figured out; my USB settings were different; the Sansa said one thing and I was looking somewhere else! I’ve not only got all my songs onto the Sansa, I even figured out how to delete one song at a time and add individual songs!

(hey, I retired from the Navy after 20+ years - I’ve only got one brain cell left!)