help with microSD card insertion please?

Hi All - I’m afraid I have an idiot question to ask - but searching threads has not answered it for me.  I just bought an E280 v.2 for my sweetie’s birthday with the plan to give it to him fully loaded.  So I also bought two 2GB  Sandisk  microSD cards .  I have loaded (and filled) the player with no problems, but  (in MSC mode)  I cannot get my computer or Sansa to recognize that there is a card inserted.  I think it might not be properly inserted, as I push it in until it clicks into place, but that still leaves about 3mm of card sticking out from the body of the player.  Is that correct?  The card will push in further, but I cannot get it to stay completely inserted.  I’m scared of breaking it by pushing too far without knowing if I should.  Any help would be greatly appreciated as I am on a time deadline here for his birthday, and I live a long way from any store I could take it to to ask for help (wilds of Idaho - 140 mile drive to a Best Buy or Target!)

Thanks

Kerizl 

It should go in and hold in flush.

I had a refurb that would not hold the card in.

Sounds like you have the same problem.

Thanks for the info. It defintely will not stay in flush.  I bought it from Amazon as a new unit not a refurb - sounds as if I need to contact them for a replacement.

Hi,

Mine doesn’t go in completely flush but it works OK. A couple of mm is left sticking out - enough that under a silicon case it can inadvertantly get pressed in far enough to unlatch.

I can post a photo later today, around 6pm UK time, if that would help. That’s about 10 or 11 hours from now :slight_smile:

In MSC mode, the μSD appears a separate USB drive, not the same drive letter as the player. In MTP mode it appears as a directory ‘External uSD Card’ off the root directory. Sorry if you knew that already…

Also, my μSD came with its own USB adapter. If yours did, perhaps you could check that it works outside the player, and that if you put a song on it, the player sees it.

Edit:

FTR - my μSD is a 4GB Sansa SDHC.

Also - if your μSD is SDHC, it is worth checking that your player _really_ is v2.  Go to Settings->Info. If the version starts V03…, it’s V2, else it’s V1. SDHC doesn’t work in V1.

Cheers

Message Edited by daytona955 on 04-24-2008 11:59 PM

My old 2GB Lexar card went in all the way, but my 4GB Transcend card sticks out a couple milimeters or so.  As you view the front of the player the writing on the card should be towards you and upside down.  The contact pins on the card will be on the back side of the card.  The card should click into place.  Push it in again and it should pop right out.

View Settings -> Info to see whether the player is finding the card. 

Thaks Folks!  I had already checked in the info settings on the player to see if the card was recognized and it was not.  I don’t have a card reader but when I used the full-sized SD adapter my camera recognized it fine, so I don’t think there is anything wrong with the card (either one - I bought two).  The player is definitely a V2, and I had already updated the firmware so I could switch to MSC mode - but the cards are regular microSD not SDHC, so that should not be an issue anyway.  If you had time to post a picture I would really appreciate it.

Thanks - a photo would be tremedously helpful if you have time!  The only position my card will hold in is so far out that the player will not even fit in its leather glove without me pushing the card further in - but even with the glove holding it in the player does not recognize it (no extra memory in Settings>Info). 

SD in

uSD in - sticks out slightly

 

uSD out - goes in this way up

nice shots, thanks for the contribution.

nice shots, thanks for the contribution.

P.S

Why is there a circle watermarked on the back of your player =P

Well that settles it - Amazon is sending me a new one and I am returning the one I have.  Thanks for the pictures - they do indeed confirm that a) I was inserting the card correctly - and b) the card sticks out WAY further than that, so obviously will only hold in the “ready to remove” position.  I am very happy that Amazon will send a replacement before receiving the defective return - I might just make the birthday deadline.

Thanks ever so for posting those pictures

Kerizl 

Amazon UK have always been good about replacements for me. Good luck!

@MrSmileyFace, the water/grease(!)mark was left by the el-cheapo silicon case I had just taken off. Has a circular recess for a belt clip fixing (not fitted).

A final thanks to you all for the help - the replacement arrived in time for me to load it together with the additional cards - and yes, they do insert properly into the new one!  I had a very happy person on his birthday.

I am glad I found this thread since I received my e280 v2 last monday and just ordered a micro sd 2gb card.

I hope that I do not have any trouble but am glad that one of the posters showed some pictures of how to insert it and how it looks when fully inserted.

Two Questions:

  1. Does the e280 itself have to be totally filled up before the sd card can be used? 

  2. Since there is very little of the sd card exposed when fully inserted, how to you remove it?

Two Questions:

 

  1. Does the e280 itself have to be totally filled up before the sd card can be used? 
  1. Since there is very little of the sd card exposed when fully inserted, how to you remove it?

 

  1. No, you can add content to either at any time. V2 players also accept video on the uSD. Watch out for the strange MTP/MSC USB mode behaviour whereby you can only see files in the player’s internal memory (from the host PC) in the USB mode you used to add them to the player. In the uSD you can always see all the files.

  2. Just push it in, & it pops out again. There is a small recess in the  player body to help.

@kerizl wrote:
A final thanks to you all for the help - the replacement arrived in time for me to load it together with the additional cards - and yes, they do insert properly into the new one!  I had a very happy person on his birthday.

Pleased it worked out OK!

My 2gb micro sd card arrived today and I initially thought that I was having the same problem as Kerizl. The card appeared inserted into the e280 correctly but when I connected to my PC, it did not recognize any device in Drive I:.

A phone call to Sansa Tech Support was of no help and I hung up in frustration.

Not giving up, I tried to push the card all the way in and, lo and behold, it clicked into place with very very little of the card extending from the unit.

Now my computer recognized the sd card and I was able to successfully copy some music to it.

Kerizl, it is possible that your original mp3 unit was not defective. I really though the card was inserted when it had more to go.

Anyway, I am glad that we are both happy campers now.

Capt -

What no one else mentioned or pointed out in the pictures was something I noticed as well. The little “hump” in the middle of the edge of the card (on top as you are inserting it; on bottom as you read Sandisk 2GB) is very “pronounced” or “sharp”. It DOES seem to bottom out there and the first time I inserted it thought that was all it would go in. But if you firmly “insist” that it goes in further, it will, and catch the little latch mechanism to hold it in place. After you push in again to release the card, remove it and re-insert it, it goes in smoothly. It seems it “wears off” that point ever so slightly, so it’s only an issue on the first 1 or 2 times you insert the card.

I have 3 MicroSD cards (all Sandisk brand) and they’ve all been like this. Kinda hard to stick it in the 1st time, but no problems after that. And yes, I COULD make an off-color refernce at this point, but I’ll restrain myself :wink:.

FOLKS - I also had the same problem. I purchased BOTH an e260 and an e280. I also purchased the new 8G microSD card - hoping to be able to use it in both players.

UGHH. It went fine in to the 260 - following exactly the directions in the link above. But when I went to insert it in to the 280 - it goes in - and springs right back out. It is a version 2 - and is NOT a refurbished unit (not marked anyway!)

I called SanDisk help - and they are making me do some silly “special amazon procedure help desk” procedure, where I have to take a picture of the unit, and send a scanned copy of the invoice from Amazon to a special mailbox - and then within 48 hours - they are supposed to “get back to me” and tell me how they will shop me a new unit.

I so wanted to love these devices - but I am getting frustrated that they won’t work right. It is like when you get a new toy for Christmas - and it is broken.

Anyway - I am wondering if this is a symptom of their machines they will start to have more of - since more people are buying cheaper memory to add to the machines!

Ugggh.

Rick

I own the e280v2. Don’t be afraid to push the Micro SDHC card all the way into the slot. It should lock in place. I had the same trouble as you when I first got my 2gb card a few weeks ago. I thought it was in correctly inserted but a small bit was protruding and it would not be recognized when connected to my PC. A phonecall to Sandisk Tech Support did no help at all. I just got bold and pushed the card all the way in because I felt I had nothing to lose. And voila, it snapped into place and is working fine.