Great solution for sansa e250 recovery mode not working.

My sansa e250 stops working when i formatted the drive with HP USB Disk Storage Format Tool.

The blue ring lights up when ever we turn the player on or plug it into computer. The player is never recognized on the computer when plugged in.(doesn’t show up under My computer as a drive). I’ve read through the stickys and have tried to enter recovery mode but it is still not recognized by the computer.

At last I find a solution that is posted on a blog and now it works perfectly.You can try this on the sansa models if you have this problem.Note that in windows XP i tried but no you give ubuntu linux a try.No need to install linux on your drive just use the live cd.

Thanks to the post

or you can download the pdf from

This is a detailed description of the e200tool recovery process, with cool screen shots too.

It’s otherwise referred to here as the Blue Ring Of Death thread.  If the boot loader or I2C rom data are corrupted or deleted, as in a case where the reserved partition is accidentally formatted, this is the method of device recovery.

It involves some delicate work with an Ubuntu live CD installation, as you will be (temporarily) operating in the world of Linux.  The e200tool application operates in the Linux environment.

Bob  :smileyvery-happy:


If you don’t have a CD on hands, you can use a PenDrive and install linux on it.

It works perfectly and I fixed my Sansa e260 on this way.

I had some problem with file permission that show the message “Permission Denied” when executing e200tool.

But is was solve coping the e200toll folder to HD (/media) instead of the bootable pendrive.