Sansa E250 Not Starting

When I turn it on it says SanDisk and then the screen turns white and then SanDisk again over and over. I put it into recovery mode and downloaded the firmware again but it still does the same thing. Any ideas???

In recovery mode DO NOT FORMAT the 16MB partition

make a folder called “Sansa.fmt” and put it onto the partition- unplug the Sansa from the computer and allow it to restart.

That file being present tells the Sansa to format itself, you WILL LOSE all your music, pics, videos (copy them to your computer before you do this!)

See if that fixes it…

When I start it the only thing that comes up is a file that says version.txt. Am I to remove that file and then make one called Sansa.fmt and restart it? If so I did that and the same problem happens. Any other ideas?

Here’s how to get to recovery mode:

Turn the player off.

Slide the HOLD button towards the headphone jack in the Locked position.

Press and Hold the RECORD button while connecting to the PC.

Release RECORD after you see “welcome to recovery mode” on the player’s screen.

You are now connected to the computer in recovery mode.

Open MyComputer and you will find a new removable flash drive labeled 16MB-FORMAT.  Open 16MB-FORMAT and create a new folder in its root directory.  Name this folder sansa.fmt and then disconnect the player from the computer.  (You might want to use safely remove hardware icon before disconnecting since it’s a good habit to get into.)

Like Will said:


Upon disconnecting the player, keep an eye on its screen.  It should say when the format begins and when it ends.  Check for any error messages you might get and post them here if you get any.

I did exactly this and it deleted all my music!!! Was that supposed to happen? I’m happy that it’s not frozen anymore and I can use it, but I didn’t expect all my music to be deleted. Now I have to start over. :( 

Yes, formatting deletes your music.

Formatting returns a disc drive to a blank state–which is why you don’t ever want to format your C: drive on your computer.

If your problem recurs, try ChkDsk. With any luck it will fix a bad file and your Sansa will start working again without a full format. 

@melinda83 wrote:
I did exactly this and it deleted all my music!!! Was that supposed to happen? I’m happy that it’s not frozen anymore and I can use it, but I didn’t expect all my music to be deleted. Now I have to start over. :( 

As Will mentioned in the 2nd post, yeah, formatting deletes all of your media files.  It’s a good idea to create a folder on your hard drive and use it as a backup of all the files on your player.

After disconnecting, mine’s frozen. What am I suppose to do ? ( And don’t tell me cry 'cause I already dit :P)
Am I suppose to unlocked it ? Shutdown it ? Remove the batterie ? Dance around ?

I finally formate three times in a row and it restart… but did format at all :cry:


I have my E250 totally frozen. It will not boot into the recovery mode per the “lock-record” routine. All I get is the blue light and nothing on the screen. Does not show up on My Computer.

Being a computer guru I am capable of totally screwing up any piece of hardware without feeling guilty. Do you have a POX vaccine routine that will allow me to cure or kill the beast?- short of returning to Sansa.

All help appreciated as long as you don’t mention the election.


Jack Elliott

LOL @ silly politiks

You can start reading here-

Message Edited by AutobahnSHO on 10-31-2008 08:16 AM

Mahee & squirrelpie -

Before doing anything drastic, try re-setting your device. Hold the power button down 15 - 20 seconds, whether it appears on or off (sometimes it’s on, but ‘frozen’ so you can’t tell). Then release. After a second or two, press the power button once to ‘wake it up’. With any luck, the unit will start up normally.

If this doesn’t work, and you have v1 devices you may have to follow the advice in the link provided by AutobahnSHO.

(WARNING: This procedure is drastic, requires more than just a casual aquaintance with a computer, and will not work on v2 units!)

Mahee - You say you formatted it 3 times but it didn’t work. How exactly were you trying to format it?

ok so i did everything but when it restarts it still says “Load main image failed witch to Recover mode” and i already did that three times but it keeps saying that on the screen. please help me

ok i did everything that you said to do but the screen keeps saying “Load main image failed Switch to Recovery mode” and i already went through this process three times but this keeps popping up on the screen i do not know what to do.:cry: please please help me

Thanks for the help. Finally got a totally bricked, blue ring of death, E260 4 gig unbricked and working properly. Used the following link for instructions Recovering a bricked Sansa. The downloaded  Ubuntu 8.0.1 Desktop run as a ‘live’ from the CD drive versus a permanent installation worked fine.

A couple of cautions:

  1. Creating an etool directory in the home folder under Ubuntu did not work properly. You have to have the etool application in the Home Folder. I’m not a Linux guru, but accomplished the necessary, by moving the created etool directory and its contents into the Documents folder, and the cut and pasting the required etool Application from there into the Home Folder- also the other three files. deleting the etool directory from the Home folder or trying to move the etool app from the etool directory up one level to the Home folder would not work. Took a bit of experimenting.

  2. Towards the end of the instructions, I had to cut and paste the other three files directly into the new 16 mb partion. The unit then reinstalledits OS and worked properly, including hooking up the the Sansa Updater properly.

All music files were of course cleaned out and date settigs, etc, had to be redone.

But it works. Only took a week or so of head scratching. Oh my poor scalp

That’s one of the basic error messages. Instructions are here.

@c93mrs_bloom77 wrote:
ok so i did everything but when it restarts it still says “Load main image failed witch to Recover mode” and i already did that three times but it keeps saying that on the screen. please help me


As C1u31355 said, this is a very common error msg. The link he pointed you to says you must contact SanDisk Tech Support for the necessary files. This isn’t exactly true. You can get the firmware files here (in the stickies at the top of the board) and you can simply create the sansa.fmt file yourself (to tell the Sansa to format itself).

Here’s a link to some other step-by-step directions. Hope it works for you. :smiley:

Btw, in the future, it would be better to start a new thread, rather than ‘hi-jacking’ another existing one. It makes it difficult to know who’s talking to who, and who’s help is for who. :wink:

I did this and it worked, sort of.  I didn’t quite know at which point to slide “hold” back off, but I did finally get it to format.  My 6yr old uses the player, it is a 2gig.  I keep her songs on an SD card and had some videos on the actually player.  Initially the player would not get past the black screen with the white Sansa logo, and then it would just go black, but still be on.  I did the start it with hold and record and add the sansa.fmt folder and unhooked it and it formatted and came up. I can play songs off of SD card.  But, when I hook it up to the computer, it won’t get past the “Found New Hardware” part.  The little window comes up saying it found it, but it says it has found and MTP Device and that is as far as it goes.  When I open explorer, it doesn’t have the sansa anywhere as a drive.  The sansa itself shows it is connected, but it appears the computer won’t see it now.  I also slip the SD back in and it doesn’t see that either. 


Edit> I read another thread about different modes so I went into the settings and it was in the MTP mode (which I don’t know what that means really) but I switched it back to the other mode and it miraculously works now.  Maybe the format put it in that mode?  Or I suppose the 6yr old could have on accident.

Thanks anyway!

Message Edited by blu on 11-11-2008 04:02 PM

Glad you fixed it yourself. Good thinking.

There are two USB modes. In the one you’re using, MSC, it just works like a flash drive–very simple. In the other one, MTP (stands for Media Tranfer Protocol), it’s controlled through Windows Media Player (version 10 and up only). When you redid the firmware it switched to MTP, because for reasons unknown Sansa thinks everybody prefers to use Windows Media Player.

Maybe you have an earlier version of Windows Media Player on your computer (or no version!), so your computer didn’t automatically recognize it. Just as well.  

Hey the problem is not being solved yet! Every time the player is recognizing the SD card I’m getting this message “Refreshing database” and the music stops playing. What am I supposed to do???:cry: