getting frustrated with media converter

Every time I try to add pictures on my mp3 it always says No Device. I have uninstalled it numerous times and it always says the same thing. No pop up comes up to register with inter video like it says. This is very frustrating nd I’m not impressed. 

you can try switching modes on the player, or perhaps uninstalling and re-installing.

worst case scenario, you can still convert your videos/pictures anyway and find them in the My Documents>Sansa Media Converter and drag and drop it to the place it needs to be in.

Something I tried from another page on this forum was to launch the program first and then hook the Sansa up and wait for the program to recognize it. Everything worked just fine after that. I had lots of trouble trying to get a video onto the Sansa but now no problems.

I wish that your suggestions worked for me but I have this person’s same problem and am not even given the opportunity to convert the file.  The files sit there in the converting program and I am not permitted to even convert them.  I am heavily frustrated with the program and want to know if there is something wrong with how I installed the program.

Fuze: updated to the newest firmware version

SMC: the file you download from the site itself

Installed without incident and completely functional but refused to function.  What is wrong with this program?! 

try unplugging your Sansa-

-open media converter, wait a minute or so after it “looks” like it’s ready

-turn the Sansa ON wait until it’s “ready”

-plug in the Sansa to the computer

-wait a minute or two more, add a video/picture

-the “convert” button SHOULD be enabled

If not, unplug the Sansa and try a different USB port. On a desktop try the back ports instead of the front ones, don’t use a hub or extension cable.

Good luck,