Fuze will not update song list at all and won't even delete tracks from formatting!

Before I explain my problem, here’s my system setup:

I am using Windows Vista Home Premuim, SP1.

Fuze version 02.01.17f

I’m using WMP 11

I connected my fuze into my computer’s rear USB ports, initially in MSC mode and double clicked the device when it showed up as a drive. I tried to drag and drop my music into the music folder and it seemed fine until the transfer froze when it encountered a media player XML file. I would also occasionally get a message (which I can’t quite remember exactly) to the effect of “the file or the destination is corrupted and cannot be transferred.”

When the transfer froze, I cancelled and then disconnected the player. I tried this a couple more times with no luck.

I next tried to do the same, but in MTP mode. Again, I had the same problem.

I next tried to use Windows Media Player. When I connected in MTP mode and fired up WMP it recognised that the Fuze was plugged in, and let me enter the sync menu. I dragged my files into the sync box and initiated the syncronisation. The progress window showed that it was working, the Fuze’s screen told me it was writing, but after two hours and 7gb of files, I turned my fuze on to find that none of the songs had trasnferred.

Well, 65 had transferred at some point, but this is where it gets very strange.

When I delete the songs in the fuze menu then turn it off then on again, the songs are still there. When I format the system, then restart, the songs reappear. It doesnt so much free up the memory as temporarily delete the database. I really don’t know what to do, because it seems to be locked in some kind of stasis where I can seemingly change the settings while it’s on, only for it to revert back to how it thinks it should be next time i use it.

It’s basically a flashy coaster at the moment. I tried updating the firmware but I dont know if that worked, and I can’t use media converter because it refuses to install on my computer, telling me to free up 125mb hard drive space, while I have 250gb free.

Any suggestions?

Message Edited by vyleside on 06-09-2009 03:28 AM

It sounds like WMP/Winamp mounts the device and resync’s it behind the scenes. Try making sure no programs like WMP or Winamp are running at all (along with any ‘agents’). Then reconnect in MSC mode, if it asks about what program to open the device with answer ‘none’ or cancel (that’s important) and see if the device mounts. Then delete the files from the device and unplug. Check if the files are gone from the device.

You might want to try the same on another PC that doesn’t ‘know about’ the fuze.

Message Edited by timn on 06-09-2009 06:32 AM

Hi, I just tried that to no avail.

Even when I select to format the device through the player’s own menus, while not connected to anything else, I still have the same problem. I hit format, the player claims it’s formatting and the song list is empty.

I turn it off, then back on and get “refreshing your media” and then it’s back again.

I connected to a laptop that’s never used the Fuze in MSC mode, tried the “tech savvy” firmware update and still no luck. It’s as if the system’s memory is completely locked and nothing I do will work.

You may be right–that the memory is not working correctly. One thing you could try, though, is to format via Windows. In MSC mode, right-click on the drive and Format… to FAT32. If by some miracle that works, then reformat it through the Fuze menus.

ooI tried that, too. I get the message “windows was unable to complete the format”.

I tried running chkdsk to scan the device to see if it had any fixable memory errors but that didn’t work either.

It looks like my problem is rather unique, so I’ve contacted the retailer to get a replacement but still hope to fix this one because I’m going away for 2 weeks and wanted to listen to music on the plane.

I would have to say that if when the Fuze is disconnected and you format it the songs are still there then the only possibility is that it’s defective  unless you have external memory too and that’s where the songs are

Do you have external memory? (uSD)

Message Edited by timn on 06-09-2009 12:37 PM

 Nope, I don’t have any micro SD cards inserted.

Then definitely it’s bad since even on its own it cannot delete…

have you tried deleting songs manually from the menu on the Fuze?  does that work?

Message Edited by timn on 06-09-2009 01:07 PM

Yeah, I’ve tried that but it doesn’t work.

There are 65 songs on the player at the moment. I deleted three and they were “gone”, then when I switched it off, then back on, it “refreshed” my song list and i was back to 65 again.