Cannot remove files, reformat, erase, update firmware

My Fuze is currently stuck. I have tried multiple ways to get it workable again, but to no avail.

My old Fuze just stopped working one day, and I was sent a new one via support. I immediatly noticed the new firmware on it and giggled at my luck to get a better player than before (I had never bothered to update the firmware as the old one was working just fine).

The problem started when I was syncing music to the player via Windows Media Player. Many songs at the beginning worked, but at one point, it had an error and all the remaining files also showed up as an error immediatly. 

The music that synced correctly does indeed work, but I cannot remove or add anything else. I have tried every way I can think of to try to remove the media: one by one in the player interface, removing them with my computer, and deleting through WMP. Each time, they return on the next boot after a media refreash. Also, every time I boot the player, it has to refreash the media, even when no changes necessitating that were made. Also, the music database system file is persistent, despite multiple delete attempts. I have tried hard resets, factory resets, formatting in the player and via Windows, and updating the firmware with the updater tool and with the .bin file, none of these solutions have worked.

I am currently running Windows Vista 64 bit with Windows Media Player 11. Please Help!

Edit: I should also list the current FW version: V02.01.09A

Message Edited by Decibel on 04-06-2009 06:52 PM

Do you really need to use WMP? Are you playing files with digital-rights information? That’s the only real reason to use WMP. 

If you’re just using mp3s, switch to MSC mode (under USB Mode) and drag-and-drop files manually. You can put them in Music or in a folder you name yourself.  That would tell you if WMP was the problem. 

WMP is not necessary, however I’m a fan of it and it never gave me troubles before.

I have had the player set as MSC mode while I tried everything I listed earlier.

I tried what you suggested. I copied music manually to the MUSIC directory where all the other music is. It copied just fine, I disconnected the drive, and when the UI came up, the media refreashed and the music I added was not there. I suspect that your idea didn’t work because the database is not changing whatsoever, and even though the file was added, the database did not get updated and it was lost.

Although it may be possible that syncing from WMP may have caused my problem initially, it does not help me to rectify the problem I have with it now. The problem is that my music database system file is broken and I cannot do anything about it.

Never say never.

Can you connect the Fuze in MSC, navigate to Music, and play the files via your computer (with Windows Media Player or any other mp3 player)?  That would tell you the files are on the unit.

But maybe it can’t find them. Disconnect and look in Artist or Album and see if there are a bunch of Unknown tracks that just happen to sound like the ones you loaded on. Then your problem is ID3 tags.

The Fuze is pretty picky about its tags, and the unit only displays information it can read from the tags. 

Or if you really think the problem is the database,  you can delete the whole thing to force it to rebuild–it’s the file MTABLE.SYS . 

The files are not there on a second boot up. Because they never got added to the database, they are deleted from the system. There are no unknown files or anything. It is still the same set of music that worked before the problem came up.

I have tried repetedly to delete the MTABLE.SYS file, and each time it rebuilds itself as the same file, making it so that I cannot change the music on the player. 

The database just indicates what files are on the unit–it’s an index, after the fact. I don’t think it can prevent files from loading.

But it seems the files aren’t getting to the unit at all, though, and that’s really worrisome. You can’t format, you can’t erase. Have you been able to write anything to the memory since your WMP problem? Did the firmware update go through?

Because now I wonder if the connection to the memory chip, or the chip itself, has gone bad–and maybe it went bad during that WMP connection, so it wasn’t WMP’s fault or yours at all. That would be a hardware problem, and if so SanDisk owes you another replacement. 

Since you’ve had two Fuzes, do you have a spare cord? You might try the other one, on the distant possibility that your unit is only making a one-way data connection–you can see it, but you can’t send to it–but that seems like a long shot. 

EDIT: Oop, had another stray thought. Copy down the date and time on MTABLE.SYS, erase it, let it reboot. Is it really refreshing itself, or is the file really unchanged? 

Message Edited by Black-Rectangle on 04-06-2009 06:55 PM

@black_rectangle wrote:
 

 

Or if you really think the problem is the database,  you can delete the whole thing to force it to rebuild–it’s the file MTABLE.SYS . 

So you’re trying to say that the only way to delete the firmware data, is to delete that file? I thought there would be more than one file to run the OS on the MP3 player (well, that’s what I call it), not that I have the same problem, I’m just wondering.

That is not the firmware. That is the database: the index made from the tags in the media files. When it says Refreshing Database, it is collecting and organizing the tags into the latest version of MTABLE.SYS, which will tell the unit what to display under MUSIC (and probably Videos).

The firmware that’s running the Fuze is deliberately less accessible to the user. 

I tried to see if the writing was completing, and as far as I can tell, the files are indeed getting to the destination. I manually rewrote parts of the MTABLE.SYS file in wordpad just to see what would happen, and sure enough, on the unplug it refreashed the meda and it was the same old story. Same songs still remained, and upon inspecting the MTABLE.SYS file again, it reset back to the old one, therefore it must be recreating the same file over and over, no matter what changes I do. I tried syncing more songs to the player, and it did show up with the ‘Writing’ dialogue on the screen, rather than just ‘Connected,’ so I imagine it knows it is getting files written to it.

This seems like I’m going to need to send in for another one, there seem to be no options left and this is just getting ridiculous. 

Have you tried to format with windows? That wipes everything but the firmware. Then use the fuze’s internal settings to format the player again before you add files. Seems to me this should give you a fresh start.

I had tried that before, but it finished with an error message saying the format didn’t complete. I’ll try it again and post with the exact message, or (hopefully) with victory.

“Windows was unable to complete the format.”