Music disappeared??

The other day the Fuze froze.  Updated firmware and all appeared good.  We then got on Rhapsody to get a few more songs before the free best buy membership thing expires.  AFTER getting songs from there, it now appears all the other songs that were on the Fuze have vanished.  The thing is, they are still taking up space on the drive.  Viewing properties shows about 3 gigs being used, but there are only 20 songs being displayed.  I’ve gone through windows explorer, some data tools, and nothing… they’re nowhere to be found - but, again, they are taking up space.  We have over 80gig of songs on hard drives, so obviously we’ve picked through them to get the 3 gigs worth of music on the Fuze.  It’d be great to be able to track down these songs so I could do a quick backup of the list, then format the Fuze and start over.  Any advice on how to find these “missing” songs??  Thanks in advance!!

Go in to the settings menu, then System Settings, then usb mode. Pick MTP and plug it in to the pc, then use explorer to look at the files. If you still arnt seeing the missing files in explorer, un plug and follow the same steps only choose MSC mode.

Excellent try, but no luck.  In MTP mode, explorer shows “Sansa Fuze…” as a drive.  In MSC mode, it shows as an E: drive AND an F: drive (with no disk in F:).  I assume F: is the micro sd slot?  At any rate, no dice…  it shows about 3.5 gig of space being used under drive properties, but neither one shows the songs in any of the folders. 

Also strange is that the Album art shows alb files with pics, but a size of 0k.  I’ve never noticed size before, is 0k right?  I mean, it takes some space just for the name of the file… 

It’s seems like all the files became hidden somehow?

Best thing I can tell ya is to use the fuze’s internal options, and format it, then before you plug it in to the computer, and depending on the method you use to transfer, pick MTP or MSC, DONT USE AUTO DETECT. Then plug it in to the PC and re add the music. Then you will know where you put it.

Well, your advice sorta-helped.  LOL  Using your suggestions and a little side thought, I switched it over to be able to accesss it as a drive.  Going into E: and using DOS and chkdsk, it shows the following:


4,077,420,544 bytes total disk space.
   14,811,136 bytes in 580 hidden files.
    6,258,688 bytes in 186 folders.
3,470,753,792 bytes in 1,288 files.
  585,564,160 bytes available on disk.

       32,768 bytes in each allocation unit.
      124,433 total allocation units on disk.
       17,870 allocation units available on disk.

…now, where the heck are these “3,470,753,792 bytes in 1,288 files” ??  Ugh… lol

Message Edited by aler1106 on 01-24-2009 03:26 PM

Wow, Sansa replied - TODAY.  …only 2 weeks wait.  Essentially the advice said, ‘format and start over.’  Well, we’ve already done that… about 2 weeks ago.  LOL.  Anyway, does anyone have any clue what happened here??  …so it can be avoided in the future?

I have the same problem.

My fuze was running good ever since I bought it last June. I occassionally get an error message that said I need to free 90 mb of music space when it the memory is barely full. I usually do a reboot and it goes back on perfectly.

A couple of days ago it showed the same error message. My files were all gone. Couldnt trace them from the pc but my Fuze’s system info says otherwise.

I tried the steps posted but files arent there.

Could it be firmware glitch? I just updated it too.

Doubt that its a firmware issue. Format your player and re load. and Try to leave 200mb free space (Just my Recomendation on space some say 100 mb).

@conversionbox wrote:
Doubt that its a firmware issue. Format your player and re load. and Try to leave 200mb free space (Just my Recomendation on space some say 100 mb).

I have 1.5m free and do not have any issues, there is a file called mtable.sys, that is your database. If it becomes corrupt or unreadable then the Fuze cannot update it. Connect in MSC mode, delete that file and disconnect the Fuze. It will rebuild the database from scratch.

Do not delete the file and then fill the Fuze without letting it create the database, then the “please free up 90Mb” error really will be true.

Conversion Box: I formatted it. Thats the only way I know that will fix it.

Hazza:Is that what it is? Like what I said I deleted everything. I dont mind reuploading everything now that I know how to fix it next time :slight_smile:

Thanks guys :slight_smile:

I came across another problem.

So i finally uploaded a few songs back on my fuze and when I switched it back on today, there were no songs saved.

does it have to do with mtable.sys too?

@rhead wrote:

I came across another problem.


So i finally uploaded a few songs back on my fuze and when I switched it back on today, there were no songs saved.


does it have to do with mtable.sys too?

There are so many factors that could be effecting your problem that I still ran out after I taking off my shoes and using my toes as well.

(Hint: Give us a bit more information to go on)

Message Edited by hazza on 02-10-2009 10:18 AM

well I use wmp11 to sync and transfer files.

I was able to successfully upload 300+ wma files. I even used it that day after reuploading everything and the next day when i turned my fuze (2gb) all files were gone, it displayed, “no songs” on the screen.

if its going to do the same thing all over again after i reupload everything then i dont know what else to do but not use it until i figure out how to fix it.

Do a soft reset by sliding the Powerswith up and holding it there for 15-20 seconds. Thish should create a refresing your database operation. If this doesnt help let us know.

i did that already.

I always do that when something odd comes up. apparently it didnt help the last time.

Upload the same songs and try again. Perhaps it was a fluke? In WMP you have Autosync turned off right? If you pluged in between the time it worked and the time it didnt that coulda deleted the files. If the files are gone tomorrow you may have a defect, or your memory went bad.

yea. i got that off.

Ill try to upload it again tomorrow and ill let you know what happens :slight_smile:



heres what happened now…

so i uploaded 160+ wma files. music disappeared again, formatted it and reuploaded it again. it worked pretty well for a few couple of times. until it showed “FAT is corrupted. Please connect device to PC and recover FAT.”

I plugged it back in but the pc cant recognize my fuze.

What should i do?

Me thinks you got a Dud. It is kinda sounding like the memory inside the player may be bad. Call SanDisk tech support, see what they have to offer.

My Sansa Fuze 8GB froze too.  And my other Sansa delete music too.  I think this product is not working.