Fuze turns off/on by itself, won't stay connected to PC


I am having problems with my less than one year old 8gb Sansa Fuze, again.  The first time I was able to correct the problem by reading the helpful threads  posted here, but now I have a new series of issues that I have been unable to solve and I won’t be able to get in touch with Sansa until Monday.  I’m kind of hoping someone might have a solution I can try.

Windows XP Service Pack 3, Window Media Player Version 11.0.5721.5268 and my Fuze has the latest firmware update.

Earlier in the week I started getting the white screen.  Usually I got it to go away by hitting the menu button repeatedly.  Resetting by holding the power button up for 20 seconds did not help.  Sometimes I would also get a flip screen, with everything shown backwards.

Friday night I went to charge and put new audiobooks on my Fuze and had no issues. I left it connected to my computer to charge.  I came back Saturday and found that my Fuze was turning off and on by itself.  It was also randomly connecting/disconnecting to the computer.

 So I totally unplug from the usb and it will not stay on and continues to turn itself off.  So I reformat using the computer first.  It still continued to turn itself off.

Then I tried formatting in both MTP and MSC modes, and was succesful in the reformatting in both modes.

I thought everything was all good until I went to put my audiobooks back on.  In MTP mode I got an error stating “do not have permission to create this file to device”.   So I tried in MSC, and it starts turning itself back off and on again, so I haven’t been able to transfer my audiobooks back on.

I also received an error stating that I had a file corrupted, so I ran the chkdsk utility and it says "the type of file system is FAT32 Volume Sansa Fuze created 1/1/1980 12:00am ##PORT#\sample.hds  first allocation unit  is not valid.  This entry will be truncated. File and folder verification is complete.  Windows has made  corrections to  the file system. 

As of this moment, the Fuze is plugged into the USB but is off and will not stay on. 

Any help or suggestions?

I also ran error checking via my computer/properties/tools and it says the error check was completed and I am still having issues with turning off.