My Fuze - RIP

I really think that my play is that messed up.  Ok so i have the most recent firmware. I was using my fuze earlier today it was all good. I tried turning it on a couple of hours later. It went from the sansa logo to white screen.  I forced it off then plugged it into my computer.  I had trouble connecting but i got it to connect. I disconnected it then reformatted. Then i reconected it, once it connected i checkd it out and it seemed alright. I unplugged it waited for the database to refresh then it turned off randomly, straight to black screen. Since then it has just gone to black screen after a few second of use. i plug it into my computer and it only recognizes for a few seconds then disconnects to a black screen.  I just noticed, whenever the backlight turns off the player turns off… 

Have you tried force MSC?

  1. Turn device OFF.
  2. Slide the Hold switch down to Lock (orange color showing).
  3. Press and hold the left button ( |<< ) while connecting the device to the PC.

If the mp3 player is detected, you can still reload the firmware of your device. Its worth a try:

Charge your mp3 player for atleast 2-4 hours, might just be low in battery.

Hope this helps. :wink:

Try pressing and holding power for a minute or two. After that, try connecting it to a computer.

Message Edited by hckrs2k3 on 07-13-2009 04:15 PM

@chux yea i tried that, still only stayed connected for a few seconds (when u connect to a computer it usualy charges amirite?, when i connect it turns even tho it has a stable “power source”)
Im going to attempt to reload the firmware (might be corrupted/damaged) but with that issue of it turning off randomly

Goodluck reloading the firmware. As long as the device holds power (upon disconnection) for the firmware to finish updating, then theres hope.

That sounds exactly like what happened to mine! It was working fine and then it had a white screen and a black oval with an orange halo around it. Sansa Support had me try updating the firmware, formatting, and holding the switch up for 40 seconds (which you could try). Finaly, they told me that it’s defective and can be returned for a new one. Best of luck!

Right, you can try to contact SanDisk, if the device is within the warranty you can ask for a replacement.