Fuze not recognised by computer and no conneted screen on player

I have had my Fuze just under a week and had been working perfectly, then today I went charge it up and write some muic onto it, to find that my computer wouldn’t recognise it, also there was no connected screen with the sansa symbol. I had previously updated the firmware but I have been listening to it since then. I have tried all the suggested options from previous posts other people have written. I tried resetting back to factory setting and reformatted it but to no avail. But there is still a charging icon next to the battery meter so it must still be charging. Please can anyone help me I am running windows vista 32 bit and windows media player 11.


Many thanks



Have you tried setting the USB mode? It’s under Settings->SystemSettings->USB Mode.

Try MSC mode, and see it the PC recognises it.

Then try MTP mode. 

I’d avoid Auto mode because you never quite know how it will connect when you plug it into a different PC…

Also, have you tried plugging it into different USB ports on your own PC, and tried a completely different PC?