Fuze freezing upon rebuilding database after firmware update

Hi there,

I’ve been using a Sansa Fuze since May this year, and so far I’m happy with it. If it weren’t for firmware updates somehow not working. I don’t know what I’m doing wrong, but every time after I install the most recent firmware, the player freezes upon rebuilding its database. So I’m stuck with whatever firmware version was current in May 2009. Fortunately I discovered the trick to read out the player’s data in spite of its messed-up state (that is, put it on “Hold” and plug it into the computer while pressing on |<<), so that I could reinstall the old firmware’s .bin file manually. Removing the extra 8 gig microSDHC card I bought with the player didn’t change anything either. However this shouldn’t be I think, and frankly, it’s been annoying the heck out of me since the first time I tried updating my player’s firmware. First I thought it was just because I didn’t use Sansa’s updater tool, but instead downloaded the zipped update installer manually. But even when I installed the official program on my Windows machine yesterday and updated my player’s firmware through it, the player gets stuck. Interestingly however, prior to updating the firmware, I formatted the player, and when I switched it on the first time after the update, while still not carrying any data, the rebuilding of the (empty) playlist worked fine. Only when I copied my songs back on it today, I ran into the same difficulties as before. So what I’m going to do now is what I’ve done before, and manually reinstall the old firmware.

Yours frustratedly


Message Edited by carbeck on 10-15-2009 08:46 AM

Message Edited by carbeck on 10-15-2009 08:47 AM

OK, so I had another thought just half an hour ago and plugged in my player. My computer would readily display the files on it, without having to resort to tricks like the one described in my previous posting above. I thought that since I have read that the Fuze is a little picky about the format of tags, I have a look at those in mp3tag. So I went and switched all tags to ID3v2.3 (iso-8859-1, how backwards :(), deleted all comments from the files, and also adjusted the tag number to include leading zeros instead of the “1/n” format. Indeed, my player didn’t hiccup anymore after rebooting. Files that were previously shown as “Unknown” are filed under their proper artist and album, and probably all tags appear in the right order. Yay!


Now how exactly do you reinstall the older firmware?

Details would be appreciated.



Uninstall the updater, which is a waste of your bootup time.

Then, Manual firmware install.

If you don’t like the version there, which is 1.02.24a, change it in the link.

For instance you can get 1.02.18a

from the SanDisk server. 

First, uninstall the updater. It’s wasting your time.

Then look at the Manual Firmware Update instructions.

The current link takes you to 1.02.28. However, you can change the version number in the link.

For instance, this will download 1.02.26  from the SanDisk server. 

Here is 2.02.26

Get it soon in case SanDisk takes it down. 

Message Edited by Black-Rectangle on 10-17-2009 08:39 AM