Sansa Fuze 4G v.2.02.28a having trouble with freezing, formatted and reinstalled firmware

My sansa fuze has been freezing since updating the firmware a couple of months ago.  Sometimes it would fix itself when I restarted, but it’s becoming progressively worse.  

Today it froze at the welcome screen like usual, but I couldn’t get it to turn on after restarting many times, after many tries I was able to connect it to my pc without the fuze freezing at the connecting screen. I decided to format it through my pc and I also reformatted it on the player as well. I haven’t reformatted it since updating it as I was trying to avoid having my files erased. During this time, I searched the forums to apply solutions that have worked for others in the same situation. 

Here are some of my problems that I think make this sort of odd. Windows no longer tells me internal and external memory, it reads the internal as drive F: and the external slot as drive G:

Also, I have a napster to Go account that I have been using for a year now synced with this player and it says the device (the fuze) is not compatible, and I tried updating napster to see if that was the problem, but napster has been giving me trouble since the new update with the fuze firmware. However, now I’m not able to re-download my music files without paying full price for a non-subscription. 

I believe the problem is with the fuze as opposed to my napster account. Any information about this, would be great.

Thanks in advance.

Message Edited by f8hopelove on 12-14-2009 09:30 AM

Have you tried switching USB mode (Settings/System Settings/USB Mode) to MTP?

Otherwise, why not roll back manually. Just unzip the .26 firmware and drop the .bin file into the Fuze drive.

Wow, that was ridiculously easy. It’s working great now.

I didn’t think about reinstalling the old version, thanks for that. I will do that if it continues to cause me trouble later on. 

Thanks alot for your help!