another Fuze problem

first the thumbwheel got stuck for no reason so i went in and got an exchange.

then as soon as i got my exchange, i upload my files and it only used 1GB of my 2GB memory.

it worked fine for a bit and when i switched it back on it said, that i need to free 90MB worth of space. i reformatted it and uploaded songs but i noticed that it takes a while for it to play a music, either it get stuck with the sansa fuze page or hangs during refreshing and i only have like 100 wma files. i tried waiting for while in hopes that maybe it was just refreshing but it was frozen.

im trying reformatting it but the computer cant detect the Fuze (its on auto detect) . Ive plugged it for more than 5 times. Rebooted my laptop, still no Fuze detected.  

can someone tell me whats wrong? can that be fixed with a few tweaks or should i just go and get another exchange? 

The Fuze OS could have been trashed when you reformatted all of thoes times.

it was acting up when i took it out of the box thats why i reformatted it.

You should have returned it!

right now, its working fine.

i just noticed that it will freezes for a bit when i turn it back on. kind of like doing a system reboot of some sort not the usual refreshing/updating and it will take a few “turning off then switching it back on” before it plays anything. its not like ive added new files it has been just like that. 

im thinking of returning it but TRU doesnt do refunds only exchanges. Im just afraid that if i go back and get an exchange it will have some sort of problem, this is my 2nd fuze in two weeks.

i think i can handle that little glitch as long as its not going to show that error where i have to free 90MB when its practically empty.

I had the same problem.  I had to download a new firmware and reload.  It seems to work.  If you try to install the firmware follow the directions for the MAC.  The windows directions didn’t work.  My sansa seems to be working now.

i have the lastest firmware, i dont think u can overwrite that or can you? ill have to wait for the next update and do what u suggested and hope it will fix it. Thanks :slight_smile:

ps: my fuze turned off itself for no reason. AHHH oh well.