Fuze Firmware update or sabotage of a working Fuze?

I have two, or I should say had two, Fuze players that weren’t brand new but worked just fine. I plugged them into the computer for the first time in a long time and the software said to update the firmware. I updated and both players stopped working.

I contacted Tech support and they basically said to bad, the players are past the one year warranty.

Now its not the cost to replace the players that bother me, its the fact that just after update, and I mean just after unplugging them one after the other they stopped working.  Logic dictates that the last action is almost always the cause of the next fault. One player failing I probably would have said its a couple years old and not a large cost, tossed it out and went on but, I happen to have two. I don’t think they planned on this. I’m not normally a conspiracy kind of person but sometime you have to face fact. If sales are down and the players your company built are too good and lasted too long how can you address this problem to get people to replace their player with a new one.


Have you tried resetting them? Slide the spring-loaded power switch on the side of the player to its uppermost position and hold it there for 30 seconds. Release and see if it will now start up normally.

The update does not kill the player. Really.

A screwed-up update–if you disconnected partway through, or there was a computer glitch–might mess with the player. But in that case you could just go to the update thread here:


and follow the instructions for manual updating–basically download the firmware, unzip the zip file and drag the file that starts with Fuze and ends with .bin (like FuzeA.bin for version 1 players) onto the player’s driveletter. If you don’t know which version your Fuzes are, just try both versions–only one will work. Drag it over, disconnect, let it update.

You can even find older firmware on the SanDisk website if you really think the new one is evil. But it’s not. Try Tapeworm’s reset first.

I must admit I was a little upset at the time of my last post and should have given myself a cool-down break. It was just that the players stopped working right after the update which made the update the most obvious cause of the failure.

You see, my handicap grandson relies on these players to get him through his day and we had to scramble to find a suitable sub while we found replacements.

A level 2 tech contacted me by phone today and together we revived the dead one but the other with a corrupted FAT will not format. I can get it to come on and it says its connected but windows can’t format it. The tech pointed me to a Sandisk shopping site where I can find a replacement and he offered me a 10% discount.  At least they gave me live personal tech support on out of warranty players and a discount on a new one so, thanks Sandisk.:smiley:

Have you tried a manual firmware update on the corrupted one? As long as you can connect, it’s worth a try. The SanDisk guys sometimes give up too easily.

The Fuze+, which replaces the now discontinued Fuze, is a whole different animal, and if you like the physical scroll wheel and buttons rather than a touch screen, you’ll be disappointed. You can still find the old Fuze on Amazon–and for better than a 10% discount.