Fuze not doing anything

I know this form of question has been asked several times (I have looked through literally thousands of messages to try and find a solution), so please don’t attack me for asking. My problem is slightly different, and I just need to know if there may be a solution or if I should just send it back. I’ve had a couple of minor problems with my player in the 3 months since I got it, but they have been resolved. I have been charging my Fuze for the last couple of days (it didn’t need to be charged that long, I just hadn’t unplugged it or used it in the last couple of days.) This morning when I went to unplug it, it had the seemingly (un)popular “white screen of death”. For awhile, nothing was making the white screen go away. So I left it unplugged for the day. When I came home from work, the screen was still white. I tried again the soft reset suggestion, which at least got the player to turn off. The blue wheel also lights up now from time to time.

When I tried to update the firmware, the only thing that was showing up for me to update is the user manual. So I updated that. I tried a few different times to check for updates, and each time it only tells me that the only available update is the user manual.

Some people have still been able to play songs with their player, and just not had the screen to see where they are navigating. I am not able to play anything. I use Rhapsody with it, and when I plug it in, Rhapsody shows an empty playlist now for this player. I have an older Sansa that I am still able to use, so at least I know that it wasn’t my computer or Rhapsody or anything like that that is messing with it.

Again, I apologize for asking this since it is a common topic, but it was a little different for me than what I had seen otherwise, and just wanted to get some input. Thanks in advance.

Do you have the V1 fuze or the V2

is it still recognized by your computer? if so try the manual firmware update instructions posted at the top of this forum.

Your gona need to do a manual firmware upgrade

Stick with the same v# if you had 01.* go with the first one

Sansa Fuze Firmware 01.01.22 download and installation instructions
All Regions - Click here to download[


Sansa Fuze Firmware 02.01.17 download
All Regions - Click here to download

  • Ensure your battery is > 50% full.
  • Extract the .zip file into a folder on your computer.
  • Once extracted, drag the file to the root directory of your Sansa Fuze.
  • Disconnect the Sansa Fuze and let it begin the firmware update.
  • Once it finally finishes doing its update, it will turn itself off.
  • Turn the Fuze on Select your language and region preference
    • Once
    its back to the main menu, head to “Settings” > “System Settings”
    > “Info”, and verify the “Version” is now 01.01.22"x". or 02.01.17"x"

Thank you for the input.

I downloaded the firmware and went through the steps. The only update it shows as being available to me is the user manual. I went ahead and did that, just to see if anything new might show up the next time I opened it. Nada. Each time I check to see if any new updates are there, it only shows that I need to update the user manual.

No change in the player yet. It’s not looking so good for it, is it?:smiley:

do you know what firmware you had on the fuze before it broke?

Honestly, I’m not sure. I’ve had it since Christmas, and unless my husband did any updates on it (which I doubt), then nothing has been done with it since it came out of the package, except for putting songs on it and listening to it.

well the fuze has 2 hardware versons and you have to put the right firmware on it i guess your just gona have to wait for the new firmware to come out.

Okay. Thanks again for your help! (And being patient with me not knowing a thing about this!)

Don’t use the firmware updater. It can’t tell whether your firmware is actually working or not–it just checks to see what the version number is. What may be happening is that somehow your firmware got corrupted.

Go to the firmware sticky note (the one near the top of the first page of the forum) and download the current firmware and install it again, by unzipping it and placing it on the Sansa,  as explained a few posts above. 

And if that doesn’t work, send it back. You shouldn’t have to deal with this sort of thing at all. 

Send it back…I’ve been having the same problems. I was waiting for the the new firmware to come out, since it was supoposed to be relesed last Tuesday, but it seems that it’s been delayed. I agree with the avove poster. It’s a little troublesom for me since I live in Japan and ordered it from israel:(

Little dissapointed since my older sansa has lasted a few years and is now only starting to develop problems!


It looks like you’ve been trying to update the firmware using the Firmware Updater.  Try the link above and manually drag and drop the firmware bin file to the Fuze’s root directory (it’s likely that you have a revision 1 device).

If the firmware is not unzipped (it will be about 16MB decompressed), the Fuze won’t accept it.

If it does not accept the rev.1 firmware, you can then try the rev.2 version.  The Fuze will only accept the correct version for each respective revision.

If this is unsuccessful, please call Support at 1-866-SanDisk, as these devices have a one year warranty.