White Screen freeze


i have a 4GB Sansa Fuze which freezes up with a white screen whenever i try to delete anything. If if i turn it off when listening to radio, when i turn it back on it gives the same white screen.

any assistance will be appreciated,


what firmware version do you have and have you tried updating?

drlucky has a good idea, but before you even do that, I suggest you back up ALL the files (not just music) before you do the firmware update. the files that you see when you go to access the MP3 Player, those would be all the files that you would want to back up before doing the firmware update. If the firmware update doesn’t fix your problem, and other problems consist, you can try to revert the firmware update to an earlier verison by copying over all the files that are on the MP3 Player with the files that you backed up. And if you don’t want to screw around the firmware update and downgrade stuff, just call Technical Support. Hopefully that should help.

Thanks for the response guys,

how do i check which firmware version i have? 

Go to Settings > System Settings > Info, and read the top line.  This is the installed firmware version.

Bob  :wink:

Thanks Bob,

it’s V02.01.17P and i’ve been updating it using the  Sansa updater

You could try repairing the existing installation by reinstalling a new copy of the existing version.  This can only be done manually , since the Firmware Updater is only designed to update to a new version if available.  Follow the directions for the revision 2 firmware from the Fuze Firmwarethread.

Bob  :stuck_out_tongue:

I followed the instructions and it updated,but still says V02.01.17P (is it supposed to change?), the deleting songs problem isn’t occuring but the radio prob is still there.

Im having the same issue it just started happining to me but when i go and try to delete a podcast i get a white screen and it changes to a diffrent song when i restart it im on V2.01.17A

ok after reloading the firmware it worked again for 5 delets but its broken again. gona do up the firmware again and see what happens.

Message Edited by Psywiped on 04-01-2009 10:00 PM

i have the same problem but if i restart it it works and is very inusual in my fuze.

i have had this red fuze 4g for 60 days and love it however yesterday the screen went blank white on me. i can not see anything. i does still charge and play music but i can not see anything and it is blank white all the time now. i have tryed many thing and dont know what to do now. i need this for work and college, the store i bought it at will not take it back even though i did buy the extended warrenty. if i send it in what will i do for the months that i dont have it? please some one help

samantha obrien

if you know the firmware verson you have upload it into the fuze again it fixes mine for a while i think its an issue in mine with the database.

 So far from what I’ve seen, lots of people are having trouble with the new firmware, so I guess I won’t update my Fuze for awhile…

@pringles wrote:
 So far from what I’ve seen, lots of people are having trouble with the new firmware, so I guess I won’t update my Fuze for awhile…

What firmware? The one from December? Cause thats the newest one.

so is my best bet then going to just to  call the support line and have them help me re format this? i called them earlier and all they could say is that they will try to re format it. maybe it is just me but i dont know how that is going to all of a sudden make my screen change from white but hopefuly it will. i have tried to ask people on here but i dont ever get an answer that helps me.

The problem seems to be fixed now! I backed up the files to my harddrive, formated the fuze and then updated the firmware (had to do it twice, didn’t work when i used my laptop, so had to use my desktop instead).

Haven’t seen the white screen, hopefully it will stay that way.

Thanks to everyone for the advice 

but hpw can he do that if his Mp3 is frozen?