Fuze doesn't see podcasts but I know they're there

My computer runs XP, service pack 3

Firmware is v01.02.26A

Lower down under settings the Fuze says I have 0 songs.  

The Fuze is in MSC mode.  I have dragged and dropped a folder containing podcasts into both the Podcast directory and the Music directory, but the Fuze doesn’t know they’re there.  I can see them when the Fuze is connected to my computer and I’m using Windows Explorer, but when I disconnect the player it says ‘no songs’.  When I reconnect the player, the computer still sees the files.

Also, when I use the ‘safely disconnect hardware’ on my computer to disconnect the Fuze, my computer tells me it’s disconnected, but the Fuze still says ‘connected’. 

I use PodNova and Juice to catch and download the podcasts to my computer.  I used the exact same method on my Sansa E250 and it worked flawlessly.

One more thing I just noticed.  There is one particular podcast that I can see and play.  I just downloaded it.  I can’t see it if it’s in a subdirectory off Music or Podcast, but I can see it if it is right there.  Its genre tag is Classical, or so it says in ID3 Editor Lite v 1.4  Is that likely to be the issue?  (I’ll check it and post an update, but right now when I try to ‘safely disconnect’ it I get a message saying the device cannot be stopped,so I’m going to shut down my comptuer, which means I’ll lose this screen).

Update: still no joy.  I changed all Genre tags to Classical with ID3 Editor Lite …version 1.1, not 1.4,  but anyway, I still only see the one podcast.

One more thing, I have also reformatted the Fuze.

If you reformatted everything’s gone.

But anyway…the tags have to be ID3v2.3 (2.2 also works most of the time), preferably ISO-8859-1 rather than UTF.  ID3v1 won’t be read.  Maybe your podcasts have ID3v1 tags.

I’m not familiar with your tagging program but you should be able to set the ID3 version somewhere. ID3v2.3 IS-8859-1 is the best. If your program won’t do it, the wonderful mp3tag  is free. Set the ID3 version under Tools/Options/Tags/Mpeg. 

I copied more files over AFTER I reformatted, sorry that wasn’t clear.  I’ll check the ID3 tags.

Okay, it’s the NPR podcasts that don’t show up, and they have and ID3v2.3 AND an ID3v1.1 tag.  So most likely that’s the problem,  BUT, I downloaded MP3Tag, and at least in the trial version I can’t access the menus the way you describe.  All I have is

two boxes side by side that show me the files in the directory structure, and allow me to change things like title, artist and album in the first box and a second box labeled Music Info which displays size, MPEG version, bitrate and MP3ID version among other things, but does not allow me to change anything.

Siiiiigh.  Why is this so hard? ![](file:///C:/DOCUME%7E1/User/LOCALS%7E1/Temp/moz-screenshot-2.png)

Trial version???

Mp3tag is freeware. You must have gotten some other program. 

Ahhh.  I tried using the link you provided, but got “NSIS Error -Integrity check has failed” so I searched for another download site, and you’re right, I downloaded a different program.

Any other site I can try to download the program you’re referring to?

Okay, I downloaded the beta version and it installed. I found all the correct menu choices, clicked them and then clicked okay.

Still can’t see my NPR podcasts.  Maybe it’s the beta version?

Beta version? This is version 2.44.

You can also find it at CNET’s download.com.

It is a very well established and stable program. Not some weird fly-by-night software.  More than 100,000 people have gotten it from CNET alone. 

You need to set the default (Tools/Options/Mpeg/Tags, Write to ID3v2.3 ISO-8859-1), find the file (under File/Change Directory or by right-clicking on the file and finding mp3tag in the menu), highlight it and Save, so it’s converted to the right version. Once the default is set it takes less than a second.

Make sure you’re changing the file on your Fuze, not on your computer, or if you want to be completely meticulous about it delete the file on your Fuze, fix the one one your computer and send it over again. 

If you have actually fixed the tag with mp3tag, and a correctly tagged podcast is on the Fuze, I’m baffled that your Fuze can’t find it–if not under Podcasts, then under Music. (While you’re in mp3tag, give it a title you can find, and call the Genre “Podcast.” )

You asked, why is this so hard? Because ID3 tags are not standardized. 

I wasn’t impugning the reliability of MP3 Tag, I was attempting to figure out my own problem.  Which I have done.  As I’m sure you already knew, choosing Play All or Recently Added doesn’t work when new podcasts have been added to the podcast folder.  They only show up under Podcasts.  Again, different from my Sansa E200, again contributing to my frustration level, and thus your frustration level.  However I have figured it out, and I figured out how to change the tags on all the podcasts I see listed in MP3 Tag.

So thank you, I appreciate your hanging in there through what has to be a frustrating exchange.  I know I was frustrated because I couldn’t understand why everything was different even though I’d bought the same brand of player.  Also I know it’s hard to provide support this way.  Much easier face-to-face.

If you have any influence with the firmware developers, you might tell them of the confusion they’ve caused.  I know I’m not the only one.

thanks again!

Ah, that explains it. I never use Recently Added because even in my E260 it would not give me reliable results. I always just go to the album or track.

I still think it’s odd that you got a security warning for the mp3tag site, but c’est la vie.  And I really do think it’s an impressive program, especially for freeware.

I run everything that goes onto the Fuze through mp3tag as a matter of course–highlight, Auto-Numbering for tracks if it’s an album (with Leading Zeros, under Tools), Save.  Seconds per album, and no tagging problems.

With mp3tag you can also see if the tagging is consistent through an album. Hip-hop albums often have screwy Artist listings because it’s Jay-Z feat. Kid Cudi, Jay-Z feat. Alicia Keys, etc.–all listed as different Artists on an mp3 player. And of course, if the original tagger misspelled the Album title on a track, you get a different album…Anyway, I’ve found mp3tag useful and sensible, and I haven’t even plunged into some of its capabilities.

Even legitimately acquired albums can have bad tags because of human error somewhere, or because of the little differences between Apple and Micro$oft. With things like podcasts, you never know what the tags will be unless you look at them.

Computers are stupid but consistent. The Fuze, with its tiny brain, is even stupider but also consistent. As long as it gets tags it likes, it’s easy to use.