Some MP3 Files don't show up on player

I just got my Fuze. I am running XP, and just installed the latest Windows Media Player (11) and also the latest firmware from the Sansa website using Sansa Updater. I will attempt to explain my problem, which I haven’t seen referenced anywhere else on this forum.

First of all, I transferred some music files copied from a CD, and using Media Player, synched those to my Fuze with no problem. Then, downloaded a podcast from http://www.wretchedradio.com/podcast.cfm , a site where I have downloaded before and used on other MP3 players with no problem. However, on the Fuze I cannot get the podcast to show up on the player itself, even though media player shows that the podcasts are on the player, and if I use Windows Explorer it shows that they are on the player, as well. Podcast does not show up under either Music or Voice. This is a very frustrating problem, as my computer believes that the files are on the player, but the player does not recognize that they are there. Anyone have any ideas?

@theusualsuspect wrote:

I just got my Fuze. I am running XP, and just installed the latest Windows Media Player (11) and also the latest firmware from the Sansa website using Sansa Updater. I will attempt to explain my problem, which I haven’t seen referenced anywhere else on this forum.

First of all, I transferred some music files copied from a CD, and using Media Player, synched those to my Fuze with no problem. Then, downloaded a podcast from http://www.wretchedradio.com/podcast.cfm , a site where I have downloaded before and used on other MP3 players with no problem. However, on the Fuze I cannot get the podcast to show up on the player itself, even though media player shows that the podcasts are on the player, and if I use Windows Explorer it shows that they are on the player, as well. Podcast does not show up under either Music or Voice. This is a very frustrating problem, as my computer believes that the files are on the player, but the player does not recognize that they are there. Anyone have any ideas?

WMP 11 likes to put podcasts in the music folder, so you’re better off copy&pasting them into the podcast folder yourself. It could also be a MSC vs. MTP vs. Auto-Defect issue. You may also find some answers here

Message Edited by Marvin_Martian on 03-28-2009 12:38 PM

ID3 tags probably aren’t in the format the Sansa likes. ID3 tag FAQ

Thanks for the quick help, folks. I’ve now installed the mp3 tag program you recommended and thereby verified that the ID tags on these files are v2.3, which they were all along, apparently. I also reset the player and changed to MSC mode temporarily. None of these have changed anything. Actually I am starting to see that this player is anything but plug and play, isn’t it? I was hoping not to have to become a computer expert to use it. Wow. This is one frustrating player.

Is the information in the ID3 tag fields correct? Album, Artist, etc.? Format doesn’t matter if the information isn’t right.

Also, set mp3tag not just to to write ID3v2.3, but also make sure it is ID3v2.3 ISO-8859-1   (there are also UTF choices, which can malfunction). Change that setting in mp3tag  (Tools/Options/Tags/Mpeg), highlight an album’s worth of tags, and Save them.

If you stay in one mode–I prefer MSC–and make sure everything that goes onto the Sansa is ID3v2.3 ISO-8859-1, which means making one change in the settings of mp3tag and leaving it that way, you should have no trouble finding files.  (ID3v2.2, which are the tags that iTunes gets online when it rips a CD, also works, but 2.3 is the gold standard) .

Yes, it would be nice if the Sansa were more flexible, but…it’s not. Every player has its quirks.  

Well first of all, one thing that doesn’t make sense is that when I use the mp3tag program, the only files that DO show up as being ID3v2.3 are the podcasts that the player won’t recognize. Every other file (that the player will recognize) shows up tagged as WMA. So I’m not sure how to reconcile that to what you are telling me. Also, I wouldn’t have a clue as to how to actually use the mp3tag program to change anything, since it is far less than intuitive how one would use it.

Another side issue unrelated to all this is why the Fuze has a folder in the internal memory called podcasts, but no podcast icon on the player’s main menu (or anywhere else in the player). This seems like it is just an outright design flaw to me. But unless I solve the issue of why it won’t show podcasts in the first place, its a moot point.

Appreciate your help, thank you. 

The Fuze doesn’t display folders. It builds a database from what’s in the ID3 tags.That’s why it can go through your files and show everything by one Artist, everything with the same Album title, etc. 

.wma files are different from .mp3 files–a different format.  There are various audio formats: mp3, wma (Windows Media Audio), m4a (what you’d get from the iTunes music store–and won’t play on Sansa), ogg, FLAC. The .wma files must have tags the Sansa likes, so don’t worry about them.  The Sansa plays mp3, ogg, FLAC and wma. 

To use mp3tag, open mp3tag and go to Tools/Options/Tags/Mpegs and make sure it is writing ID3v2.3 ISO-8859-1.  Save that setting and you’ll never have to touch it again.

 When you highlight something in mp3 tag, you can change any of the fields: Artist, Album, etc. 

So find the folder with your podcasts by using Change Directory under File or just using CTRL-D (shortcut). Highlight them all, and you can change them all at once. Type in Podcast as Genre, and Save. Now you can find all your podcasts by looking under Genres and finding Podcast.Once you save them all as podcasts, they will also save as ID3v2.3 ISO-8859-1, since you already tweaked that setting. 

You’ll still have to change Artist or Album individually, or in groups, to your liking. Unfortunately podcasters around the world have not agreed on a convention for naming or tagging podcasts.

Another thread has suggested using the free versions of Media Monkey or Ziepod to gather podcasts. They may have other tools built in.   

OK, I just downloaded a Wretched Radio podcast and it didn’t show up on my Sansa either, so I looked at it mp3tag.

Here’s the problem. The podcast is at 32kbps, which is VERY low fidelity. kbps (kilobytes per second) is the amount of data (kb) for each second of audio. Typical, mediocre-grade music mp3s are 128 kbps. High fidelity starts at about 192 kbps.

The Sansa just doesn’t play mp3s at such low bitrates. Your computer will, and other mp3 players may, but the Sansa doesn’t. 

There’s a solution, but it does involve tweaking. Get the free Media Coderand convert  (Transcode) the Wretched podcasts to a higher-bitrate mp3 file (slide the slider for quality about 2/3 of the way over). It will make the podcast palatable to the Sansa. 

When I did that, I had already saved the tag in mp3tag to   ID3v2.3 ISO-8859-1.  I don’t know whether the original tags were in UTF, which may also have been a problem, but even with correct tags the Sansa didn’t find it.  

Also, the guy left the Title field blank, which won’t help you find the podcast. How difficult would it be for him to title them Wretched Radio March 25, or whatever? Instead, all the info is in Comments. He did put Podcasts in Genre, though…

This is the problem with podcasts. They don’t follow any particular convention. You happened to hit on one that’s outside the Sansa parameters. 


By the way, the default in Windows Media Player is to copy CDs in wma (Windows Media Audio), not mp3. There’s nothing exactly wrong with wma, except that Micro$oft owns it and some players don’t play it. You can go into the default settings of Windows Media Player and permanently change it to rip CDs to mp3, which is a more universal format, in case you ever want to transfer your music library to another player sometime in the future.

It won’t matter with the Sansa, but iPods and some other players don’t play wma. Which is another reason programs like Media Coder exist–to transcode files into more compatible formats. 

Message Edited by c1u31355 on 03-29-2009 01:06 PM

@c1u31355 wrote:

OK, I just downloaded a Wretched Radio podcast and it didn’t show up on my Sansa either, so I looked at it mp3tag.

 

Here’s the problem. The podcast is at 32kbps, which is VERY low fidelity. kbps (kilobytes per second) is the amount of data (kb) for each second of audio. Typical, mediocre-grade music mp3s are 128 kbps. High fidelity starts at about 192 kbps.

 

The Sansa just doesn’t play mp3s at such low bitrates. Your computer will, and other mp3 players may, but the Sansa doesn’t. 

 

 03-29-2009 01:06 PM

I wonder then if MediaMonkey does more than just tag my podcasts then, because I get several that are in MP3 format at 32kbps and they play fine, on my Fuze or my Clips. It’s just people talking though…I wouldn’t even think of trying to do music at that bitrate( that would be a crime against fidelity) , and most of my podcasts are higher than 32kbps…some 64, some 80, etc.  :smiley:

Ah, you are a wise person. Many thanks - it is nice to get a definitive answer rather than just “try this and that”. I will dowload the suggested program and let you know the results (assuming I’m able to figure out how to use it).

What Marvin Martian said about Media Monkey is interesting–you might try using it to grab a Wretched Radio podcast and see if it somehow fixes it up.  It would be great if that were the simple and complete solution.


Post again if you have trouble downloading Media Coder (get the 32-bit version–only true geeks have 64-bit computers and you have said you are not a big computer person).

I just tried to update my Media Coder  and the download link seems to be a little strange, though it might just be my popup blocker. If you can’t get it, I can upload my older version easily enough. 

It’s a geek program, so yes, you’ll have to do some initial setup. Here’s what mine says at the moment–I don’t remember if these were defaults or I tweaked them. 

Left side: 

 For Encoder, choose LAME MP3.

Resample: Original

Channel: Stereo

 Audio ID: 0

 Gain: 0db

Right side: 

 You can leave the output folder as Original Folder, unless you want to have it put new files in a special folder.

Rate Mode: VBR   That means variable bit rate, and it adjusts depending on your file to get better fidelity in less space. CBR is constant bit rate. Practically speaking, only certain dogs can hear the difference, but…

Bitrate/Quality: 7   You can choose whatever sounds good to you. Higher quality = bigger files. That’s why Wretched Radio is cramming his down to 32kbps.

Algorithm Quality: 1 or 2, unless you have a really old slow computer.

  

You can leave those settings once you have them–and, again, they may already be there. 

With File, browse to the Wretched Radio podcast you downloaded and Add. If all your podcasts are in one folder, you can do them all at once–highlight them all and Add. 

Under Transcode, click Start Transcoding. Pretty soon, you’re done.  Hope they play for you.


I know this is way too much geekness for what should be easy. And you’re right–it should be easier.

The Sansa is more finicky about the files it likes than some mp3 players are–especially the ID3 tags, which are usually the culprit, and for which it really should be more flexible.

The tradeoff is in its price, its sound quality (which is better than iPod or many other mp3s), its features (voice recorder, FM), and in a pretty simple user interface. No gadget is perfect.  And once you wrap your head around the Sansa’s logic, it’s pretty straightforward.

Well, I converted it to 160 bit and now it does show up on the player. Problem solved - thank you!

I do hope the people at Sandisk monitor this site. They should be aware of just how user-unfriendly the Fuze is for the average user who is trying to listen to a podcast. Maybe then they could make it better. 

Glad it worked.

You shouldn’t have the low-bitrate problem with most other podcasts–it’s more likely to be the ID3 tags, which was why that was the first bit of advice you got. With any luck, most podcasters are using ID3v2.3 and doing good tags. 

For the next glitch, mp3tag (as a first resort) and Media Coder should do the job for you.

Congratulations–you are now part geek. 

Thanks - by the way, the Media Monkey program did fixup the Wretched Radio podcasts so they could recognized - somehow. Niot sure what it did, but they show up now on the player without my having to change the bitrate manually.

@theusualsuspect wrote:
Thanks - by the way, the Media Monkey program did fixup the Wretched Radio podcasts so they could recognized - somehow. Niot sure what it did, but they show up now on the player without my having to change the bitrate manually.

Glad to hear it! :smiley::smiley: