Fuze doesnt connect to the PC, just charges

When I connect my fuze to my PC, it only starts charging, it doesn’t connect. At first everything was fine, it connected fine, and suddenly it doesn’t, please let me know what can I do.

Note: Nothing appears on Windows, no installing drivers nor anything, just starts charging like if I connected it to a wall charger. I tried on another computer and the same happened.

More info: OS: Windows Vista SP1

Fuze Firmware: v01.02.26P

EDIT: I tried with 2 cables, original sansa and another generic one.

Message Edited by steinkill on 05-02-2009 01:49 PM

Go to the Device Manager and check the device drivers- they may have been interrupted.  Did you change USB modes?


I had this same problem for the longest time.  It would start to connect, then immediately not, and the Device Manager would always show an error symbol indicating an interrupted driver, though it could ID the device.  This was in either usb mode or auto, and after several reformats, removing and reinstalling all USB drivers, etc.  For some reason it didn’t go away until I reformatted my hard drive and reinstalled Windows (not b/c of this problem, I just do that from time to time).  Anyway, I’m running XP SP3, no clue how that fixed it, but I haven’t had the problem since.

All drivers are fine, I even deleted them, and windows installed them again, and yes I tried with all USB modes, I mostly use MSC. I think it got faulty somehow, I tried on another computer and nothing happens, not even an error message on windows, it just starts charging.

steinkil, did you try formatting your Sansa and installing new firmware?

Since you had similar results on another machine that suggests it’s the firmware/cable or something related to the Fuze and not the PC. I’d try one more different PC first and if it’s the same then it must be the cable or firmware or the like.

I had to return one Fuze because it always thought it was hooked to a power pak after being hooked to a PC and would not power-off only go into standby mode. Maybe you have a similarly strange problem in that it ‘thinks’ it’s hooked to a power pack not a PC.

Message Edited by timn on 05-04-2009 03:03 PM

Yea maybe its that, I already tried formatting it, and nothing, its already running the latest firmware.

whenthe device is not detected by pc how to update the firmwear and i downloaded a firmwear and it open in vlc…dont know ho to use it…

To install the firmware you must be able to copy the file to the device. So it sounds like you need to return it for replacement.