Fuze 4GB will not recognize track information changes

Alright then, I’ve been having some problems with my Fuze MP3 player. When I upload new music to the device, the ID3 tags all come out the way they’re expected to. However, if I remove music that is on the player and replace it with the same tracks with updated ID3s, it will not recognize the change in title, album, or artist, though the song file itself will update. I know this because I have had problems with songs with the same name or songs accidentally given the name of another song, which has resulted in incorrectly labeled music.

I’ve tried formatting the player, I have tried removing the music manually from the file system, I have tried changing the USB mode and deleting the file that I’ve been told holds the ID3 data, and I have tried all possible permutations of disconnecting and letting the player recognize the changes. This includes removing all music from the player, disconnecting it, confirming that there is no music on the system, changing the USB mode, deleting the file with the ID3 information, turning the USB mode back, plugging it back in, putting my music back on the device, and the problems have not been resolved.

It’s likely it’s just being fickety and there’s something I’m not doing right, but this is the second Fuze I’ve owned - I’m very fond of the model and have gone so far as to return a Fuze+ in favor of the older model - and the first one never had this problem. I’m willing to try anything within reason to solve the problem, so hopefully someone can direct me in the right direction.

The tag version should be ID3v2.3 ISO-8859-1. If you “update” to ID3v2.4 you are going to have trouble. The Fuze is picky about tags–it won’t handle ID3v1 either.

The best way I know to standardize your tags is to get the free mp3tag.


When you install it, allow it to add itself to context menus.

Under Tools/Options/Tag/Mpeg go to Write and choose ID3v2.3 ISO-8859-1.

Then go to an album folder, right-click to see mp3tag as an option to open it, highlight all the tags and Save the tags, and you’ll get Fuze-friendly tags.

I do use MP3tag to change ID3s in my library. I changed it from ID3v2.3 of some type to the ISO-8859-1 option. I went in and deleted the music from the device and reuploaded it and it didn’t change.

I did NOT format the device, because I had pictures I didn’t feel like putting back on. It’s not a big deal, because the images are nothing compared to my music library. If formatting the device will force it to reread the tags and fix the problem, I’ll do that.

Mtable.sys is the index of tags. Deleting that should force the Fuze to reconstruct the tag database from scratch. You said you had tried that, but…try it again. You’ll need to connect in MSC mode. (Settings/System Settings/USB Mode)

That really should do it if the tags in the current files are right. Make sure you haven’t done the stupid thing I’ve sometimes done, which is to fix the tags on the computer copy rather than the Fuze copy.

If that doesn’t work you probably are going to have to format it, sorry to say. It’s the nuclear option–takes the Fuze back to factory clean, destroys all user content, but shouldn’t leave any old tags in memory.   Then make sure you have run all your music through mp3tag before you put it back on. .

Actually, the problem wasn’t as expected at all. I think it turns out the problem is that Windows Media Player, which I use solely to sync my music to my MP3 player, had a library with out-of-date information. So after updating the Media Player, I refreshed it’s records of my library and everything worked as desired. I’ll just have to make sure I do that if I make changes to existing songs in my library.

Thanks for all the help, guys, guess it was on my end.