Sansa Fuze not recognizing music updates?

Right then. This is the second Fuze i’ve owned and I’m extremely pleased with it, but I’m still having a problem.

I’m very scrupulous about making sure the ID3 data for my songs is right. Every once in a while I have some songs I have to update or change. If you don’t know what ID3 is, thats the information in an mp3 file that tells stuff like title, author, and album.

The problem is, when I delete songs, and then put in versions with different ID3 tags, my computer recognizes the difference, but the Fuze doesn’t. It uses the ID3s for the previous version. I’ve tried deleting the songs from the player in explorer, I’ve tried formatting all the data from the player, and for one song I even went in to the menus and deleted the song. It recognized the song had been deleted and replaced; the song was gone, and then it showed up in the ‘recently added’ menu. But it will not change the ID3 data.

Any clues as to why? Much appreciated.

What are you using to edit your tags?

What format is your tags?

Are you using MTP or MSC mode to transfer the songs to the player?

Are you editing the tags of the song files on the player or on the computer?

I suggest that you format the player through the computer, reinstall the firmware, then format the player again through it’s own settings.  It may just be a glitch in the firmware.

If you haven’t already formatted the Fuze, put it in MSC mode, connect and delete MTABLE.SYS . That’s the index. The Fuze will reconstruct one using the newer tag data.

Also, tags for the Fuze should be ID3v2.3 ISO-8859-1. One easy way to assure this is to get the free editor mp3tag

Let it add itself to context menus while installing. That way you can right-click on an album folder and have mp3tag open it.

Under Tools/Options/Tags/Mpeg set Write to ID3v2.3 ISO-88591.

Then all you have to do when adding an album is highlight the files, Save and the version is correct. Another useful part of mp3tag is Auto-Numbering under Tools  The Fuze does best with the Leading Zeroes option: 01, 02, etc. instead of 1, 2 or 1/10, 2/10.

If you are already using another tag editor, make sure at least that the version is ID3v2.3 and preferably ISO-8859-1,