Problems with Id3 recognition.

Howdy all… Just got my wife a Sansa Fuze for christmas, and she couldn’t be happier. However, whenever I upload the music, it has set Id3 tags inside the mp3 player. I’ve edited the tags with mp3tag v2.42 and with wmp11, and neither is really working. Any advice? Still showing unknown artist, etc.

Make sure MP3Tag is set to write ID3v2.3 ISO-8859-1 version tags. Sansas are very picky when it comes to ID3 tags and what they will and will not read. :wink:

:frowning: not working so far. I’mma try to DFE (delete everything) and re put stuff on. 

Easiest way to start over with a clean slate is to use the on-board FORMAT function. Done! Couldn’t be simpler.

Some people find it easier and more reliable to edit the tags with the files on the computer, and then transfer them to the player, but I have had good success editing them with the files already on the player.

These are .mp3 files you are trying to get the tags right, aren’t they? Make sure to hit the SAVE button in the top left-hand corner of MP3Tag too. :stuck_out_tongue:

Try using the Windows Media Player Converter.

It’s showing up with the artist name and everything on every media player on my computer. I made sure it was the version you specified. The Sansa still says 



01-Main Theme (the file name)

I’m going crazy here… I know computers well enough, but if I can’t figure it out, my wife is probably just going to return it for something like an iPood.

I’m going to revisit the sansa converter thingamajig and see if that helps some :) 

@cheezbawl2003 wrote:

I’m going to revisit the sansa converter thingamajig and see if that helps some :) 

If you’re talking about the Sansa Media Converter, that’s only for videos and photos, Not music. Besides, yours is a tag issue; you just need to track down the inconsistency.

Check out this post:

and this one:

(Scroll down the thread on this one. There’s an image showing the correct settings in MP3Tag) 

Hopefully, one of these (or other) posts might help you isolate and solve your problem. :wink:

Haha, using the same settings as him, apparently with the same result. I’mma keep poking, because at this point it’s a vendetta D:

It’s a cool little thing, too. I have an iPood 160G and I like it well enough, though it’s kinda buggy in it’s own way. I used to have a Creative Zen Xtra 60G and that was cool too. Worst thing the company ever did was switching from Creative Explorer for music organization to drag-n-drop interface that allowed all the Id3 tags to go batshet. 

Do you have foreign language characters/Unicode in your titles, artists, etc. id3 fields?  Sansa doesn’t support that.  Every time I’ve had non-ASCII characters, I’ve ended up with Unknowns as genre, album, title, and/or artist.  I’ve made sure all my id3 tags are ASCII and no more Unknowns show up.

Message Edited by GuyScharf on 12-27-2008 03:51 PM

Well, although they had no ASCII problems in them, we seem to have found a workaround. The first time we tried syncing with WMP11, it didn’t work. For whatever reason though, dragging the album FROM the WMP11 media library seemed to import everything properly.

O_o GG windows.