Artist Tagging Not Showing Up

Hi all, I just purchased my Sansa Fuze (I had an e250r before).  I dragged and dropped all my music files (mostly mp3) and they play fine.  I am running a PC with XP.  The song title tags came through just fine.

However, none of my artist tags are showing up (all are “Unknown”).  I went through all of my files before loading to make sure all of the file names were okay, and used Stamp ID3 Tag Editor to make sure all of the artists were there (and consistently spelled).  I did not have any problems with this on my e250r.

I browsed through the forum and found a couple of “techie” extensive discussions, but nothing I understood.

Any help would be appreciated!!!  Thanks.


What version of tags are you using? The need to be V2.3.

MP3TAG is recommended by 4 out of 5 Sansa Gurus. :wink:

Set it to write ID3v2.3 ISO-8859-1 tags for optimal results.

I downloaded a free version of Stamp ID3 Tag Editor - it is version 2.04.  Is there a stamp editor you would suggest (free maybe???) that might be more up-to-date.

Thanks for the response.  I’m trying to get my new player loaded for a long road trip this weekend, and this has been slightly frustrating.

MP3Tag is free.  Go forth, download, and try it.

Okay, have downloaded MP3Tag, pulled up my directory with all of my files.  Went into Tools, Options, Tags, Mpeg, Write, and set the option to ID3v2, ID3v2.3 ISO-8859-1.  Then selected all of my files, then did a save.  It looks like it converted most of the files (except the .wma files).

I tried deleting all files from the Fuze, then dragging and dropping about 20 files.  They are still coming up with “Unknown” for the artist.

I also tried doing the firmware update, but it is crashing my PC.

I’m up if anyone has any other suggestions !!!  Thanks.

Got it . . .

I was cruising through the rest of the forum and found a thread about connecting to car audio that talked about:  Settings, System Settings, USB Mode - the default is “AutoDetect”, it needs to be set to “MSC”, there were a few other threads that talked about this mode also, but I did not get it until now.

I changed to the MSC setting, stripped all of my music from the Fuze, fixed all of the song tagging through MP3Tag, and reloaded, and poof, all of my artist tags are there.

Yeah !!!