I used mp3tag but .....

MSC mode always.

I used Mp3tag to change album for multiple songs. To make sure it’s changed, I closed and reopened Mp3tag. Surely album was changed. Closed Mp3tag.

Put cursor on the songs. dbpower shows old album. Disconnect Fuze. Navigate album. Still old album. I am completely lost. Help please.

If I understand you correctly, you edited an album in MP3Tag. Did you click the SAVE icon in the upper left-hand corner?

Did you edit the files that reside on your computer? Or the files that are on your player? Some believe they must be edited while on the computer and then transferred to the player, but I have had good luck with MP3Tag editing them directly on the player.

If you edited them on the player, and then un-plugged from the computer, the ‘refresh database’ process might still be reading the ‘old’ info. I would connect in MSC mode and look for a file called ‘mtable.sys’ in your player’s root directory. This is your music database file. If you delete this, your player will build a new one from scratch with the current information on the player upon start-up/refresh. You should then see any changes you made to the ID3 tags.

Could also be the tag options in MP3Tag.  Make sure you are using ID3v2 with ISO encoding.

Thanks.

This is what I have been doing:

  1. I edit directly on Fuze. Mostly successful. Just a few folders are refusing to be changed repeatedly. 

  2. I always saved as ID3V1. Will try ID3V2.

  3. Yes, I saved ID changes.

I will try your recommendations and write back.

Under Tools/Options/Tags/Mpeg set Write to ID3v2.3 ISO 8859-1.  Those are the best tags. v1 won’t be read by the Sansa–that’s your problem.