Fuze 4gb keeps disconnecting and reconnecting to Windows 7 pc... when the battery is low.

So I just got a Fuze and I like it.  Got a good deal on it.  Windows 7 picked it up and transferring music is not a problem when the device is fully charged.

What IS a problem, is that when the battery gets low and I plug the Fuze into my PC to charge… it keeps connecting and disconnecting.  The fuze control center program keeps popping up and going away, popping up and going away… frustrating.  I have tried both MTP and MCP modes (actually in MCP mode the control panel doesn’t come up all and it doesn’t recognize that the device is attached).  I have tried different USB ports.  No hub involved here.

Here is the rub… if I charge the Fuze up first (plug into a Kindle USB charger), once it’s charged it connects fine.   

Ran the firmware updater and I am on the latest firmware it had available, 1.02.31. 

I would like to know how to resolve this issue as I don’t always have the little Kindle USB charger with me, and it would be nice to actually charge from a PC… which is what was the original intention, right???

Other than that I like it and really dig the FM radio tuner.  It is wicked strong!  

Can you charge anything over USB from that computer?  Does it the Fuze charge if you try a different PC?  Could be a busted USB controller on the PC not providing enough power.

I would try the Fuze on a friend’s PC to verify that it charges and is communicating properly.  Let the computer and the Sansa mind meld for a while, and see how they do.

My gut feeling is that there may be a communications issue with your PC.  As both modes are affected, don’t forget that MTP is a virtual mode supported through Windows Media Player.  At the nuts-and-bolts level, we need to have a stable driver (and registry entry) in MSC mode.

Plug in the player, on your Win 7 machine, and go to the Device Manager.  Uninstall the device, then unplug.  After a wee wait, at least 30 seconds, plug in again, and allow Win 7 to reinstall the device driver. You should do the same thing in MTP mode.

The Fuze will drop charging duties if it is busy establishing a data connection.  Using a USB adaptor, there’s no data. so we see that the Fuze is quite happy sharing electrons with the charger.

Checking the USB status (charge current for a USB 2.0 port, was designed by a programmer, not an EE.  That’s a shame, since the charge current is what I’d love to see in a data field.  “The device is working properly” just burns me up.  I can plug in a memory stick, a Type A cable with cut wire stubs, a book light, or one of those “humping dog” gizmos, and see the same message.

Bob :smileyvery-happy:

It charges my wife’s Phillips USB MP3 player just fine. 

Bob, you need to get a life. :wink: I got a Fuze 4GB from Woot! and it got me to Texas and back on a single charge. 

borchman wrote:
I got a Fuze 4GB from Woot! and it got me to Texas and back on a single charge. 

Driving or hitch-hiking?

Woot action!  Check your device- Settings > System Settings > Info and see if your Fuze is a revision 1 or 2 machine.  (The first two digits will let you know.)  Be sure to update it to the latest firmware build.

The Fuze has pretty decent battery life for those long trips.

Bob  :wink:

It could be a defective cable(a problem with the power conductors) or the pc isn’t putting out enough power. If you are using a desktop pc, are you connecting it to a rear USB port? Front ports often don’t provide enough power. I assume you are connecting it directly to the pc, and not using a hub or USB extension cable.

If your pc is a notebook, make sure it is plugged in before connecting the Fuze.

Message Edited by JK98 on 06-17-2010 11:18 PM

Hosers, all.

A powered 4 port usb hub has solved my problem.  “duh I think yer cable is bad”  I THINK NOT.  The Fuze apparently just sucks too much power. 

So I solved my own problem with a $5 usb hub.  Yippee.

Good stuff!  When the device is hungry, that supply voltage is important.  This is why the device requires a USB2.0 port.  Though the throughput may be slower on a 1.1 port, as long as you have a powered hub, you should be fine!

Glad to see you are up and running.  Now if I could just figure out why Win7 sometimes suggests I try a 2.0 port (all of mine are 2.0), all would be right in the universe.

Bob  :smileyvery-happy:

The Fuze doesn’t suck too much power. It will charge okay with 500 ma, but using a 500 ma wall charger I have, I left it charging for many hours and it still indicated it was charging, but then when I plugged it into a USB battery pack with an 800 ma power output the player imediately indicated it was fully charged.

One other thing to consider. Laptops on battery power often revert to USB1 to save power. Even if connected to AC power, some might revert to USB1 with certain power saving setting. Something else to consider. If you have a USB1 peripheral plugged in, I believe that everything on that USB controller is downgraded to a USB1 connection. I guess USB1 maximum power is lower than 500 ma.