Frozen at "Disconnected"

Well, it was working just fine and all my fears had gone.  A few books, radio, and music plays later, now it freezes!  Not even a month later!!

Had it plugged in to charge, unplugged to go home and it is frozen.  Tried to plug back in to see if that would do it and nothing.  The computer won’t even see it…

Somebody… Help!!!

Hold down the power button for at least 20 seconds, then restart it.

I’m having the same problem.  Holding down the power button for 20 seconds or up to 2 minutes does nothing.  Anything else to try?

Well the “Disconnected” screen went away on its own, but now there is a blank screen and it won’t turn on.

Was there battery charge?  You can try leaving it plugged into a power source for 24 hours–that sometimes has worked.

Will it connect to the pc? If so, then format the player using the pc, deleting all the content on the player. If it won’t turn on after that, then download the firmware and reinstall it on the player. If you can’t get it to connect with the pc, then return it to the store or send it back to Sandisk for replacement.

I’m not sure.  It was working fine.  I left it on the charge (USB to PC) last night after deleting a bunch of music on it.  Pulled it off this morning and had the D/C screen with no response.  I’ll try leaving it plugged it in and post back if I get it to come back

No luck when plugging it into PC either.

Well, when I held down the power button did nothing for me.  Reconnecting to the PC did not work… did not see it.  Finally, the power died, and plugged it into the PC… only then did the PC see it and charged… works for now… go figure!