Frozen 2 GB fuze (no white screen)

So I checked before posting this to make sure no one answered this problem before, and it doesn’t seem as though anyone has. I just got a 2 GB fuze yesterday, and twice now it’s frozen. Both times it’s frozen on the “now playing” screen, although neither time had any music been playing (I think both times the music had been paused). I think I had been deleting music on the player both times, but I can’t remember for sure. The first time the player un-froze after about half a minute. The second time, however, it stayed frozen for about five minutes. During that time I tried turning it off, and hooking it up to the computer (after of course, pressing various other buttons). Neither action un-froze it. I was finally able to turn it off after about five minutes. I turned it back on immediately, and it worked fine.

If anyone could help me out, that’d be great. Other than this little glitch, I absolutely love my fuze =)

I’ve had this problem before, try a firmware update. This problem should be fixed with the newest firmware update.

Actually, I had already installed the newest firmware before using the player to play music. I just looked to see if there was a new update, just in case, but there wasn’t.