Four Sansa Fuzes three with Screens gone Black in five weeks.

_Vintage_ Fuzes, well taken care of.  This hasn't happened to me in eight years using Fuzes.  (I get the white screens of death; these I can escape from with time .)  Won't go about the suspicious timing. is more than suspicious.

     USB set to MSC (always).
     Installed Windows Media Player 11 (on my orphan XP).  Held ‘on’ switch for sixty seconds, released then held ‘on’ and plugged in to computer.  For the two middle ages players the response are  ‘unrecognized USB device’ no response but I can find it ‘my computer’ on disk drive J.  Attempting to access drive J leads, every time, to computer asking me if I want to format drive?  If yes then I’m told that windows failed/can not format drive.  And back to do I want to format?
     Installed Sansa Updater 2.1.3.  This does not recognize any appropriate device.  (For all three.) 
     The oldest Fuze elicits no response at when plugged.  Not even as unrecognized USB device.
     Windows Explorer no longer recognizes players.  Sansa Fuze no longer renames drive as Sansa Fuze.
     The last, newest Fuze (bought ~18 months ago) is fine…so far.

          Also tried the program “DeviceRecoverySetup”.  Nothing at all happens.

         Other common proceedures available?  Or the un-common?  (Does anyone else still use Fuzes?)



Do they do anything at all when you turn them on? Does the wheel light work? Any signs of life at all?

Suddenly having the same problem on four different Fuzes would suggest to me that it’s a problem with the connection or computer settings, not some epidemic among the Fuzes. But all I can do is guess.

And if they are getting old, I suppose eventually the backlight will burn out and you’ll get a black screen–in which case, requiescat in pacem.

Here are some guesses:

Have you tried different cords? You can get all kinds of wacky responses simply from a bad cord.

Do you have a microSD card in the slot? Is it possible that the drive J: you are looking at is the microSD slot with no card in it?

If you do have a card in the slot, take it out, just to limit the number of variables.

There is zero reason to use the updater. Just download the last version of the firmware (check the version of your Fuzes), unzip it and drag it over to the Fuze driveletter–if you can find the drive.

Holding the button, as you are doing, simply forces MSC mode. There’s no need to do it if you are already in MSC.

Also, WMP 11 shouldn’t make any difference. It might, perhaps,  if you were using MTP mode. But if the problems started when you installed WMP 11, how about finding a Restore point for Windows  (using Control Panel, I think it’s under System or Recovery in XP) from before you installed WMP 11?

Additionally, how about storage? Where are these stored? 

Ah, kitscht, always good for a completely irrelevant post. 

I looked at the original post again.

I have had bizarre moments when my Fuze, always on MSC, somehow gets switched to MTP or Auto and for some reason turned unrecognizable. It has happened with some firmware updates that switch back to Auto, or if you accidentally pressed Restore Default Settings. 

To make absolutely sure you are connecting in MSC, plug the USB into the computer and hold down the >> button while plugging the connector into the Fuze. 

I truly do not understand holding down the button for 60 seconds, letting go, and pressing again. You’d hold down the button if you got the white screen of death to make sure it was fully off and reset, not as a prelude to turning it on. 

In Windows Explorer, does the drive say (Driveletter):  Sansa Fuze?  Not Removable Disc (the card slot) or Media Device (MTP connection).  

As I suggested, you could roll back to before you installed WMP 11 or try a replacement cord.