i need help with my sansa fuze :(

well my player , just when i turned it off ,went black but it is still on

when i got home the battery was drained so since i have no charger, 

i plugged it to my computer ( which i usually do when i charge it ) .

when it was plugged into the pc, it says that the device isn’t recognized

i tried to format the player but it always appear that it cant be formatted ?

i dont know where it can be repaired because the player was just sent for

me from my aunt in U.S … what should i do ? :frowning:

—aby (philippines) 

First, with the unit OFF, slide the power switch down to Hold (orange dot shows), open Windows Explorer on your computer, plug the cord into the computer, hold down << and connect. That forces the Fuze into MSC mode and the unit should pop up in Windows Explorer. If it does, let it charge up.

Then follow the directions in here on MTP mode (although it ws answering a different question). 

Reconnecting

Message Edited by Black-Rectangle on 07-25-2010 08:44 AM

it still doesn’t turn on … it also appears that the usb device isn’t recognized … :’(

Do you have Windows Media Player 10 or 11 on your computer? Open WMP and look in About to see the version. If it’s 9 or under, go to support.microsoft.com to get a newer WMP and install that. Then try connecting. 

If that doesn’t work…

Depending on your version of Windows, you need to look at Device Manager after connecting.  In my XP computer, I can right-click on My Computer, click Manage and click on Device Manager. If you have Vista or Windows 7 it may be different–you’ll have to look at Help. Try connecting again, open Device Manager (which shows what’s inside and connected to your computer)  and see if you see a yellow triangle with an exclamation point. Right-click on that, Uninstall it (not disable) and reboot and reconnect to see if Windows will fix the driver to connect the Fuze. 

the device is now connected . it still doesnt turn on . but the computer already reads the device [G:]

when i open it , it says it needed to be formatted . so i clicked ok … but it wasnt able to be formatted .

what shall i do next ? 

Message Edited by girlinpink27 on 07-25-2010 09:05 PM

What do you see in Windows Explorer? It should show two drives with successive letters of the alphabet, like G:SANSA FUZE and H: Removable Disc 

If you can see SANSA FUZE, you could try manually reloading the firmware with these instructions:  Firmware

Message Edited by Black-Rectangle on 07-26-2010 09:35 AM

ive tried holding the l<< while powering yet it still doesnt work . nothing appears on screen . and it still doesnt show up “SANSA FUZE [G:]” . what only appearson the screen is the “REMOVABLE DISK [G:]” (and i cant open nor format it) . and sometimes the usb device isn’t recognized . im losing hope :frowning:

Message Edited by girlinpink27 on 07-30-2010 04:53 PM

Look up instructions (in Windows Help) on getting to Device Manager. Connect the unit, go into Device Manager and if you see a yellow triangle with an exclamation point, right-click and Uninstall. Then reboot and reconnect.