For those having problems updating SSD firmware in a Macbook

I searched the forums high and low and didn’t seem to find anything, so I figured I would post my findings and hopefully save someone else the headache.

If you are having problems updating the firmware on your SSD in your macbook and you have removed your superdrive (à la Optibay) and are trying to boot the ISO/disc from an external CD drive enclosure, it simply will not work. The update is linux based and will not recognize externals. You will need to either remove your SSD and put it into a computer that has an optical drive hard lined into the computer, or you will need to remove your optibay and reinstall your superdrive (just for the update). It’s a huge pain in the ass, I know… but the update will work fine afterwards. After you’re done the update you can remove your superdrive again.

Hope this helps!

I also had to do the same.

Some people may want to try this:

(read both first post and my post, which is the 3rd)

or this:

Before opening their Macbooks though.

But as I mention on my long post at the first link, I tried and tried and had to open and get the superdrive there.

Also not easy to find information at this Forum (which is why I am linking these 2 threads as it seems like no one cares to merge them).