Can't Update Your Firmware on Mac? Here's The Fix!

Several people on the board reported the same issue I had with the SanDisk Extreme firmware update CD for Mac - it simply froze up my computer and wouldn’t boot or perform the firmware upgrade. Well, I figured out the problem, at least in my case, and even though I got very negative replies the last time I asked for help with this issue here, I’m going to post the solution.

The firmware update utility is Linux based, and it seems to scan all your drives before you get started. If you have a bunch of external drives that are Mac-formatted, Linux doesn’t know what to do with them.

Unplug everything that is connected to your Mac, especially external storage drives. THEN try the update CD. Once it finishes, you can plug everything back in.

It worked for me!

Tried it. No go. :cry:

The firmware CD software hung while “waiting for drives to settle” on Mac. (SSD plugged in via USB appears *not* to work on Mac OS 10.6.8 or Windows 7.

Had to plug SSD into Windows PC internal drive controller to get it to work - fast. Probably should work plugged into internal drive controller of Mac too.

I had to open my Macbook and get the superdrive back in there (SSD internal as well).

More info here (my post on that thread, which is the 3rd post):

and here: