Updated: How to Update SSD Firmware on a Mac w/o Optical Drive (MBP, Mini, etc) - Working Solution

Hello All – 

There seems to tstill be a lack of an official way to update our SSD drive firmware for Macs. There are a few convoluated solutions floating around via searches and old posts. With FW211 there still are posts asking the same questions, so I put together a working solution that isnt that hard and I have verified works on my own systems.  There was a post over on crucial forums with a similiar method, however it missed a key step that inlcuded the copy of the actual firmware image over to the drive.


-Windows Based machine for running Universal-USB-Installer- (a VM running on Fusion/Paralells is fine, even if its on the same machine that you are updating

-Firmware download v211 for your respected drive model

-USB Drive 1 or 2GB, etc

-rEFit - Download from http://refit.sourceforge.net (will only need this temp)


  1. On the Windows VM/machine download Universal USB Installer

  2. Download the firmware for your drive

  3. Download the rEFit tool, run it and install it on your machine, this is only needed temp, you can simply remove it once the drive is updated.

  4. Plug in the USB drive and make sure it mounts into the VM or Windows machine

  5. Format the drive manually via Windows Disk Utility (I prefer this over using the USB Installer app)

  6. Run the USB installer app on the Windows side, select Old Syslinux and select the ISO firmware file

  7. Once completed the drive will now have a bootable partiion along with the firmware image file needed for proper flashing

  8. Reboot your Mac and press COMMAND-C

  9. Using your keyboard arrow keys go to the right and select boot partition from USB “partition name”

  10. System should boot into the Linux Kernel and start the firmware image loader

  11. Proceed as normal

  12. Boot back into OSX and remove the EFI folder on the main OS drive and double check that the Startup Volume is the SSD drive (Settings - Startup Volume - verify what drive is checked)

  13. This puts the boot menu back to normal and your drive should also be updated.

I dont think this is missing anything, I did it quickly so let me know if you are having problems and I can try to help!


rEFit not working with latest OSX. I have a pc running as well and did a bootable usb with the image but the MacBookPro is not seeing it at startup even though it shows on the finder. My 2009 MBP optical drive is shot, total POS. So I can’t even upgrade using a CD.

Basically I cannot do the firmware upgrade at this time.

Thought I should give my 2 cents here.

First quick thing to say is that the method described above on the main post of this thread will NOT work for most people (including me). I spent a whole day trying this, hoping to avoid opening my MacBook again.

I am using Mountain Lion on a MacBook 13-inch, Aluminum, Late 2008 (MacBook 5,1). I was using rEFInd (a fork of rEFIt), but in the process I have tried both rEFInd and rEFIt but there was no real difference on the results. rEFIt is abandoned but still works quite fine on Macs, I just took the extra care of installing it manually, as advised on the rEFInd site (the installer may cause errors on some Macs).

My Mac has the infamous Nvidia MCP79 SATA controller that runs on 1.5Gbit/s(instead of 3Gbit/s) with the “normal” firmware. So I got the R211m firmware which downgrades the SSD to 3Gbit/s which is the max speed for that Nvidia firmware anyways.

Now to get that iso to an external USB, I tried using the Windows SSD Tool Kit, Universal USB Installer and Universal USB Installer Everytime I created the bootable USB pendrive I tried booting with Command-C, alt(option), standard rEFIt/rEFInd and whatever I could think. I even got the USB recognised some times, but turns out that the Apple firmware my computer uses does not like to boot Legacy Linux systems from external drives. If your firmware is different you may have a chance though.

With all that I knew it would also not boot from an external CD drive as well. So I just gave up, opened my Macbook, got the Superdrive back in place, burned the iso on CD, booted holding the C key (no need for rEFIt/rEFInd) and after 10 seconds from Boot I had the new firmware running, gave it a test/check on sysPref. Then turn off again, open, remove superdrive, put caddy/HDD back, close, assemble superdrive on its external USB case again, etc etc etc…

Too bad I found this post just few minutes ago (maybe that should be merged here):
I did not find before because the post name is so long that I could not see a “Mac” there. Also, the information on that thread if compared with this one you are reading are pretty much opposite (which would make me wonder, would it work anyways?)

There is also this thread which mentions another possible issue (if having many USB drives connected during firmware update):


If anyone can take the time to merge the threads, that would help people finding the information.

Meanwhile, I will post a reference to this thread on both of them.

I hope this helps other people not to waste one or more days of their lives like I did.

The upgrade is a must (either the R211 or R211m depending on yout chipset), things get a lot better after it.

BTW, I have also activated TRIM with Trim Enabler and no problems so far.