FLAC - all files under unknown artist (unknown album)

Hi, As the title says all the FLAC files I’ve uploaded to Clip Sport are place under Unknown Artist/Unknown Album. All FLAC files are from official FLAC files from record label (Linn, Domino, etc), so I think the information inside them should be correct. I don’t have any problems with mp3 files, those are placed to correct folders with correct names. I suspect that Clip Sport can’t read the information from FLAC files correctly, or am I doing something wrong ? Is there something I can do (other than use mp3 files instead)

Are the tags for the files filled in?  That’s what the Clips use to identify files, as a general matter.

MP3Tag (Internet freeware) can be used for this (although I haven’t used it with FLAC files, I understand that it works just fine there).  The Clips want ID3v2.3 ISO-8859-1 as the tag format (set within MP3Tag), which I assume works with FLAC files as well. 

@platypus wrote:
Hi, As the title says all the FLAC files I’ve uploaded to Clip Sport are place under Unknown Artist/Unknown Album. All FLAC files are from official FLAC files from record label (Linn, Domino, etc), so I think the information inside them should be correct. I don’t have any problems with mp3 files, those are placed to correct folders with correct names. I suspect that Clip Sport can’t read the information from FLAC files correctly, or am I doing something wrong ? Is there something I can do (other than use mp3 files instead)

What are the bit and sampling rates? 16-bit, 44.1kHz is what Clips like. 24-bit, 96kHz (and anything higher) are generally not recognized.

Update:  Apparently, tags don’t currently work with FLAC files on the Sport, leading to the situation you mentioned.  (MP3 files are fine.)  Unknown, at present, if this can be fixed.  Unfortunate.  And sorry that you were one of the first to discover this.

One thing to try:  can you navigate to the files via separate folder/card navigation?

I checked with Mp3tag and not all files have the tags filled (which was a surprise, because those come from record company).

Nevertheless some of them has tags, and still all of them are placed to Unknown Artist/Unknown Album.

Mp3tag show that the format for FLAC is FLAC and for mp3 it’s ID3v2.x

In my opinion this seems like a bug.

oops - I answered your previous comment first.

I’m not sure if I understand your question, but yes I’m able to see the files and use them, but they are all in the same folder.

It seems this player doesn’t like to read the ID3 tags, unlike previous Sansas. With FLAC, MP3, and iTunes-purchased M4a, it seems the only way to get an album to play in the correct order is to access it via the Folder menu, and even then the filenames must be numbered correctly, like so…

So each album in its own folder, looking like the above, seems to be the necessary method. 

@platypus wrote:

I checked with Mp3tag and not all files have the tags filled (which was a surprise, because those come from record company).

Nevertheless some of them has tags, and still all of them are placed to Unknown Artist/Unknown Album.

Mp3tag show that the format for FLAC is FLAC and for mp3 it’s ID3v2.x

 

In my opinion this seems like a bug.

You may have missed my comment above yours above, but it appears that, at present, tags do not work with FLAC files (while they are fine with MP3 files)–unknown if this can be fixed.  And so the current options are, to convert to a different file format (such as MP3) or navigate for those files via the folder and card options.  Sorry . . . .

@miikerman wrote:


@platypus wrote:

I checked with Mp3tag and not all files have the tags filled (which was a surprise, because those come from record company).

Nevertheless some of them has tags, and still all of them are placed to Unknown Artist/Unknown Album.

Mp3tag show that the format for FLAC is FLAC and for mp3 it’s ID3v2.x

 

In my opinion this seems like a bug.


You may have missed my comment above yours above, but it appears that, at present, tags do not work with FLAC files (while they are fine with MP3 files)–unknown if this can be fixed.  And so the current options are, to convert to a different file format (such as MP3) or navigate for those files via the folder and card options.  Sorry . . . .

See my post above…:wink:

@marvin_martian wrote:


See my post above…:wink:

Yep, and mine a few above that, addressing the OP’s issue–wanted to make sure he hadn’t missed it, as I wrote.   :wink:

Ok - thanks for the information and hints.

I probably need to play with the device a bit more to find out what I like to do. What I won’t do is to tag my over thousand records again - but maybe my tagging is good enoug - need to check and also try the folder navigation (I’m new with sansa).

At least it seems that I need to use mp3 files. Which of course is not a big deal, because I’m using this mostly outside in a noisy environment and there it really does not matter if the file is lossless or not.

Still … would love to see this bug fixed in the future.

Yes - this is correct. I tried the folder navigation and there the albums are in correct folders, but as you said those are not in correct order (if filenames are not numbered as 01,02, etc …). Thanks.

@platypus wrote:
Yes - this is correct. I tried the folder navigation and there the albums are in correct folders, but as you said those are not in correct order (if filenames are not numbered as 01,02, etc …). Thanks.

And the folder navigation works the same way on all three formats I tried it with, MP3, M4A, and FLAC. It’s the only way to play an album in order, unless you want to make a playlist. So in your case, using MP3 instead of FLAC would still yield the same results, unless the filenames were numbered on the MP3 version and not the FLAC.

 

It’s worth noting that previous Sansa players used a lot more battery power to play FLAC than MP3, but we don’t know yet if this player will be the same way or not. 

For whatever it’s worth, adding the track number at the beginning of the song name is pretty standard at this point, to keep tracks ordered for play purposes where there are no tags or database playing.  Very easy to do, in batch form, with tag editors such as MP3Tag. 

Same disappointment here: I bought this player beacause it was supposed to read FLAC. Sure it can play the file, but none of the tags is recognized :mansad:

I hope some firmware update will fix this soon …

Ciao,

LoneCat

I purchased the Clip Sport in September of 2014.  The support for FLAC is lacking.  FLAC files will play, but they do not show up properly under the Music menus.  This behavior is the same whether the files are Internal or on the External card.  They do not show up properly unless I select the Folder menus.  But that is because I have the files laid out under the Artist, then under the Album.  Under the Music menus, they show up under ‘Unknown Artist’ or ‘Unknown Album’.  This is a definte problem as FLAC files work as they should on the Sansa Fuse that I also own.

Support for mp3 and m4a/acc files work properly.  But, they are lossy, whereas, FLAC is lossless.

I have edited the tags as described in another post, but this has not worked.  Hopefully version 1.18 of the firmware will fix this issue.  I am currently on version 1.17.

I upgraded to the latest firmware, v1.22. This has gotten much, much worse. So much so that the player is now totally useless. When powering on the device, I now get the following error: ‘Refreshing media’ flashes by quickly. Then ‘File system error! Restart the device or Farmat to Recovery!’ Then the player shuts off.

I was able to get the device to come on and get to the menus. I selected the format option. But the problems continued. I eventually connected the device to my Windows PC via the USB. I selected to format the internal storage from Windows Explorer. I was then able to power on as before and get to my media. I then had to format my external storage as I could not get to the Music that had been previously loaded. Issues with “Unknown Artist” and “Unknown Album” persist with the new firmware. I previously had v1.17 installed.

I was able to figure out why the FLAC files were showing up as “Unknown Album”, “Unknown Artist”. It was because of the tags. I had support turned on for ‘FLAC ID3v2’ tags. Once I removed the v2 tags and only had the v1 tags, FLAC files appropriately showed the Album and Artist as it should. This is not documented anywhere in the User Manuals. You can check on the tag versions with a program such as Mp3tag. Using Mp3tag, you must configure the following options under Tools. Options: 1. Tags, Mpeg. Uncheck Write ID3v2 and Remove ID3v1. Check Read ID3v1, ID3v2, Write ID3v1, and Remove ID3v2 2. Add directory, select all files (CTRL-A) 3. Right-click, select ‘Tag Cut’, click OK. 4. Right-click, select ‘Tag Paste’, click OK. 5. Copy FLAC files to player

Actually, the ideal ID3 tag for ALL Sansa players is ID3v2.3 ISO-8859-1 (which is actually different from ID3v2). Having said that though, FLAC files have their own tag format.

I think you have your MP3Tag settings misaligned. This is how mine are set-up and I have never had a problem with FLAC files (or MP3) out of the (literally) thousands of files I have ripped and transferred to my various players:

READ:

ID3v1 (checked)

ID3v2 (checked)

APE (unchecked)

WRITE:

ID3v1 (checked)

ID3v2 (checked)

APEv2 (unchecked)

ID3v2.4 UTF-8 (unchecked)

ID3v2.3 UTF-16 (unchecked)

ID3v2.3 ISO-8859-1 (checked)

ID3v2 only if ID3v1 too small (unchecked)

REMOVE:

ID3v1 (unchecked)

ID3v2 (unchecked)

APE (checked)

If your FLAC file tag settings aren’t right (and aren’t being read by the player), it’s due to a wrong setting in whatever ripping software you are using. Hope this helps. :wink: