Fix for greyed out "convert" button in Sansa Media Converter

The geniuses at SanDisk are not posting the correct SMC version on the main site-the latest version  is here: . I have contacted tech support, as this version has beeen  out since mid June, but they are still linking to version 4.220 on the main site. Uninstall 4.220 and install this version; it worked for me immediately.


Please attach the site where the incorrect SMC is located.

I have the E250, everything seems to be working fine- except I still cannot get that Greyed-out convert button to open up! I downloaded the right SMC (as per the first message in this post, .236), and re-installed it a second time, but still no headway… I have XP, quick-time, etc…

What next to try? I read on another post that one can use wmp, but mine does not seem to have a photo converter.

Sorry SansaMe! The site where the incorrect file is located is: Sandisk asks you to register to downoad, but it is the same smc version whether or not you do.

greentchr, Did you uninstall the previous version first? Please make sure that you do not have the player connected to your pc when you re-install 4.236; you may want to try a registry cleaner to remove clutter left over from the original install. CCleaner works well for me. Is your player visible in the little window in the upper left? My original post was for the Fuze; I do not know if this S?MC version will work with the e250.

Thanks for pointing out the 4.220 link; this one was previously broken, and obviously missed the 4.236 file link.

As a footnote, I like to try and “mess up” changes and installations to see If I can replicate concerns.  With the upgrade from 4.220 to 4.236, I tried installing 4.236 over the (still installed) previous build.  The software recognized the issue, and 4.236 works well.

Bob  :smileyvery-happy:

Thanks Galion for the ideas… followed through and still no convert button… no, it does not show the player connected, however the problem at this point lies in converting the photos rather than synching them. The convert button never leaves it’s grey state.

I don’t think it is a problem with the MP3, since I have tried it 1) without the player hooked up while starting smc 2) with player hooked up while starting smc 3)hooking up player after starting smc 4) importing media without player hooked up at all…

It must be a computer and/or software problem…  possibly a user problem- I don’t claim to be technilogically literate!:smiley:

SansaMe or Neutron_Bob - any further suggestions? I am not trying to get videos on- just photos that are in a jpeg. format

Message Edited by greentchr on 07-16-2008 07:54 AM

Will have that fixed.

So, in the mean time, is there another program or way to put jpeg photos on my 250? Not that it is of the dire-est importance, but just something I really would like to do… 

You can use WMP 11 to transfer JPEG images to the Fuze.  However, if you have done some Photoshop work on your JPEG images, then some may not work after transferring with WMP 11 (Unsupported Image).  The SMC seems to be able to transfer these touched up images just fine.

Message Edited by SansaMe on 07-16-2008 08:17 AM

Unfortunately you will need the SMC for the e250.  I am assuming you are talking about the e200 series.

Is there really a need to use the Sansa Media Converter to put .jpgs on your Sansa? All of my album art is in .jpg format & they just get dragged’n’dropped with the song files. I know the SMC converts them to a .bmp format, but why I don’t know; the Sansas can & do read jpegs fine.

I’ve even dragged’n’dropped .jpg pictures from the computer to the Sansa w/o going through SMC, and they showed up just fine (as long as they aren’t too big).

Edit: Sorry, I have e200 series players, is it different with the Fuze?

Message Edited by Tapeworm on 07-16-2008 08:32 AM

You are correct…as long as they are not too big.  I just take the guess work and use SMC…quick and easy.  To each his own.

 Yes, mine is the e250

drag 'n drop does not seem to work for me- I get a message saying it is not supported… for music, I use WMP to make playlists and then synch it- it seems to be the only

However- if I find another way to convert the jpeg photos to the other format (bitmp?) then perhaps the drag 'n drop will work…? I have a Roxio photo program on this computer- perhaps it can change formats.  I guess it is time to call up my kids for advice :wink: 

What version is your e200?  Take a look on the back botton right area of the device.  It should be v1 or v2.  I am testing with the SMC with a v1 e200 and it seems to prefer being in MTP mode. 

Be sure you e200 is in MTP mode, plug into the computer and launch the SMC.  Add some images and hopefully you can use the Convert button.

MTP mode:  Settings/USB Mode/MTP

I just added another thread RE a grayed out convert button in SMC. I have a new Fuze. any suggestions welcomed.