Firmware has ruined my device

Hello, I tried to install rockbox on my Clip Zip. Big mistake–it doesn’t work any more. It is frozen and does not respond to any button presses. My computer no longer recognizes the device when plugged in.

I’m afraid there may be no way to fix it. Is there anything I can do to fix it?


Reset it. Press and hold the power button down for 20-30 seconds. Release, then press again momentarily to start it up.

If this doesn’t seem to work, repeat the procedure, holding the power button for up to (and maybe slightly past) a minute. This long of a reset is rare, but some have claimed that ti worked when the normal 20-30 secs. didn’t work.

Do as Tapeworm says. If that doesn’t work, press the left button and try powering up. I doubt it will work, but if it shoud you will be in original firmware. If it does work, copy the original firmware to the root and repeat the procedure. This will reload the original firmware and all should work. There will be some left over Rockbox files in the root directory.

If you really want Rockbox, don’t give up. I installed according to the Rockbox instructions and everything worked fine. I removed it but might give it another try, but was just my choice, nothing to do with the way it worked.

thanks guys, I was able to reset the device and now it works perfectly with rock box! I guess the firmware just needed to crash the first time in order to  get acclimated to its new home :smileyvery-happy: