file transfers are going at painfully slow rates suddenly..

Hello, I have a Sansa Sandisk 8GB (with 16g expansion card) - have had it for the past year but today when I plug it in and try to transfer mp3s onto it, the files go at such a painfully slow rate it would take hours for just one 11meg file! I have tried different USB ports, reseting my computer, reseting the mp3 player ect - I can’t update the firmware as the process seems to get stuck. Please help!

Also I’m now getting errors that it cannot copy the file (the device has either stopped responding or has been disconnected)

I have also tried deleting files (it lets me delete them)

Not happy about this! :confused:

You might try a hard re-set of the player–hold the on button down for 30 seconds or so, and then re-start.

It might also be a problem with the cord. Do you have another one you can try?

Also, are you sending to the card or the internal memory? 

And it wouldn’t hurt to take a look at both card and internal memory in Windows and see if there’s anything odd in there.

Yeah, I tried different usb cords (4 different ones, just to be sure!) and the 30-second the reset (multiple times for that too) - also it seems to crash when I disconnect it from the computer sometimes, other times it crashes when it refreshes the file-list. Whole thing seemed totally screwed up. Annoying as I have only had it since march this year, not exactly encouraging.

By any chance, did you buy it new within the past 12 months?  If so, it has a 1-year warranty in the U.S. (2 years in the EU)–SanDisk will replace it under the warranty.

Yes, if it’s under a year you should be under warranty.

But a couple of things from your last post:

If you disconnect by pulling the USB cord out of your computer first–instead of disconnecting the little plug from the unit–Sansas often give you that white screen. It just happens.

The slow or crashing Refresh means it is chewing on a file it can’t digest. It could be something corrupted, or a big image file someone stuffed into an album folder, or just about anything. If you’re going to return or get rid of the unit anyway, you might as well Format it–which erases all the files you have on it–and see if the problem goes away. Settings/System Settings/Format. It’s the nuclear option but it sometimes fixes things.

Format does leave the firmware on there–it’s not like formatting a computer hard drive. But if you really want to try starting fresh you could format, connect, and reload the latest firmware too. Don’t use the Sansa Updater–just follow the manual instructions. The firmware updates are in the sticky threads.

And you’ve probably already done this, but have you taken out the 16GB card to see if the problem is in the internal memory or in the card? .

You could test the card with h2testw, but that does overwrite everything on the card.

I did try the format yeah, but it litterally did nothing.

Today I finally got time to look into it again - I could not delete any files nor could I put any files on it at all, it crashed windows explorer each time. Now it will not even turn back on.

I removed the 16GB sd card a week ago, so yeah - all these problems are independant of the SD card - The SD card works perfectly in my other mp3 player with no problem too (I’m glad I got a backup!).

I bought it originally off in March this year. It says “Sold by Amazon EU S.a.r.L” - I do see an option to return or replace items - but when i click on it, it just says "This item is no longer eligible for return. The return window closed on 29 Apr 2014. " - I am very unfamiliar with this process in general as i have never actually had to send any product back in my life.

At this point, it would be an exchange under the warranty, generally done with the manufacturer.  Here is SanDisk’s info., to find your local SanDisk contact point:

Just to clarify what Milkerman said, the “eligible for return” is Amazon’s window, not the SanDisk warranty, which is two years in Europe. You just have to contact SanDisk directly rather than Amazon.