File crash when using SecureAccess_Win

Dear all,

I have important crash when I moved them via SecureAccess_Win 1.1.19755.

When I moved around 20 files (around 50Mb size) from my Windows 7 64 bit machine to Sandisk Extreme USB 3.0, it seems normal. However when I try to open it (after normal disconnect the Extreme from my machine), I found that the file size is “0”. Of course, I wasn’t able to open the files. Then I tried many times, result is the same. 

Then I downloaded new version SecureAccessV2 5.4.16 and tried to fix the problem. After the installation, it seems more problem, there is no file on the list in My Vault list. However I can still see my encrypted files with appropriate file sizes in the USB drive in Windows Explore. in this case, it seems that the new version Secure Access ruin the encryption database/index.

Anyone has suggestion. Many thanks!

:smiley:   Hi Centerout,

Dear member of SanDisk Community, welcome.

Friend, according to all requests for help on this issue, I elaborated the following article, that you can see this link:


Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                              (Google translated)

Dear Alfred,

Thanks for your help. However the information is not applicable on my case.

I had used “RunSanDiskSecureAccess_Win” when I encrypted the files. Therefore the system create a “My Vaults” folder in the UDF; it is different from using “SanDiskSecureAccessV2_win”.

I now can still see the files in the “My Vaults/MyVaults/FILES/00000000”” folder when I use Windows Explore to browse. I can see the files size. All the file names are number; I believe they are encrypted and renamed.

The problem now is the RunSanDiskSecureAccess_Win or even SanDiskSecureAccessV2_win. I am not able to see those file on the list in the program. In normal situation, all encrypted files are listed in the My Vault list in the program. I can drag or open a read only etc.

I believe the database or index of the program is crash therefore there is no linkage with the files.

Any suggestion? Many thanks!

:smiley:    Hi Centerout,

I’m sorry, I did not know the version 1.
On Google, I found this old version, RunSanDiskSecureAccess v1_Win.
You can download it here, SanDisk SecureAccess 1.1.19755.0, (free):

Try installing it in the UFD, and maybe you open the old vault.

Also, I’ll leave these links, which deal with the migration between v1 and v2.

If this, do not solved your problem, do not grieve friend, that in the Forum’s members very experts, who know the version 1.


Regards, Alfred.                                                (Google translate)

Dear Alfred,

thanks for you help anyway!

:smiley:   Hi Centerout,


Please, see link:



Regards, Alfred.