RESOLVED: SecureAccess 2.0 Windows—Able to open .dat Files

   I recently posted the issue of not being able to open SecureAccess 2 with my original .dat files.

   Today, I finally resolved the .dat files issues with an 0x80070052 exception and/or procedure to reinstall the “sandisksecureaccessv2-win” installation file to fix the issues. I took the time to create another long descriptive post since there are many users with the same problem with little to no help.

   Please note that I had 13,114 files and 1 folder with 998 MB. There are no warnings on file size exceeded during the copy process a week ago. I have 28.3 GB free out of 29.4 GB. I am not sure if it is a limitation of SecureAccess program or just the procedure of saving files to an opened “My Vault” file.

   Lesson learned: Do not cut/paste all files from the SanDisk USB drive to Windows PC. First. run the backup function from the Tools menu within “My Vault” before you do anything else. Second, you only need to save SanDiskSecureAccess Vault (File folder) to your PC/MAC.  Otherwise, here is what I endured until I finally got access to my encrypted .dat files again.

   For new users, here are the information and steps that I did. I succeeded on one drive, as a test, but not the other because of the file size in nature.

(1) Original files on SanDisk Ultra 32 GB USB drive copied to Windows 7 Desktop in a folder — named SanDiskSecureAccess—ORIG.

(2) Format the drive, as exFAT.

(3) Copied and ran the “sandisksecureaccessv2-win” installation file on USB drive as administrator.

(4) Created the same password used for the original Vault file.

(5) Copied one working document file to “My Vault” and opened to see if the document will open, and it did.

(6) Closed “My Vault” — File | Exit.

(7) The files listed on the USB drive are:

  •  sandisksecureaccessv2-win (application), and
  •  SanDiskSecureAccess Vault (File folder).

(8) Accessed “SanDiskSecureAccess Vault” folder, and the files listed are:

  •  System Files (File folder),
  •  {730bcdbd-224c-4111-9c07-6513879e4f0f}.dat  13 KB  (Note: this is the exact file size reported inside “My Vault”)
  •  desktop (Configuration settings), and
  •  vault (icon) 232 KB.

(9) Accessed System Files folder, and the files with file size are:

  •  A5000644B2750C91.enk   1 KB
  •  encryptstickconfig.enc 2 KB   (Note: Time stamp changes each time “My Vault” file is closed.)
  •  filesys.enc  1 KB   (Note: Time stamp changes each time “My Vault” file is closed.)
  •  stickauth.enc  1 KB   (Note: Time stamp changes each time “My Vault” file is closed.)
  •  USB Flash Drive-A5000644B2750C91.idx  1 KB   (Note: Time stamp changes each time “My Vault” file is closed.)
  •  USB Flash Drive-A5000644B2750C91.idx.bak  1 KB

(10) Accessed “My Vault” file again, added another file, and closed “My Vault” file.

(11) Accessed “SanDiskSecureAccess Vault” folder, and the change listed are:

  •  System Files (File folder),
  •  {730bcdbd-224c-4111-9c07-6513879e4f0f}.dat  13 KB
  •  {540cac0d-5ff4-4fc0-b81e-9921ab59d7c8}.dat  16 KB (NEW)
  •  desktop (Configuration settings), and
  •  vault (icon)  232 KB.

(12) Copied “SanDiskSecureAccess Vault” folder to Windows 7 PC Desktop as a test.

  •  Verified file size — 10 files, 1 folder with 262 KB.

(13) Deleted all .dat files and System Files of “SanDiskSecureAccess Vault” folder on USB drive.

(14) Right-clicked for Properties on my original “SanDiskSecureAccess Vault” folder in “My Document” folder on PC and unchecked “Read Only” attributes.

  •  Copied and pasted the .dat files and System Files folder into “SanDiskSecureAccess Vault” folder on USB drive.

(15) Ran the “sandisksecureaccessv2-win” (application).

   Only this time, it prompts for a new password meaning that I will not be able to access the “My Vault” file of the encrypted .dat files. By typing in the new password, it created a new “My Vault” file, which there are no files to see. It is an infinite loop to no resolution. I have spent hours after six days when I copied the files to the Windows 7 PC without running the backup function when I was not able to add any more files into “My Vault” file. Again, one of the suggestion was to format the drive to exFAT 32, which did not work anyway at the time.

   The theory is that this process should allow me to access the original “My Vault” file, which is about 1 GB. Please note that I was able to do the same process, outlined in the former, with a different drive (Cruzer Glide 32 GB) with different “My Vault” files that are much smaller in size. I am working with the new 32 GB Ultra drive. The process for the larger “My Vault” file will not work on Cruzer since I noticed the name reference for both USB drives is different in the System Files folder. You will notice the difference when sandisksecureaccessv2-win application prompts for a new password and creates a new “My Vault” file.

   Last, each time, even with a formatted USB drive, when I ran the sandisksecureaccessv2-win application from the Windows 7 PC desktop, it looks for the USB drive and installs the program and creates a new “My Vault” file.

   VOILA! I resolved the problem by moving small sets of .dat files until I reached the offending 0x80070052 on two .dat files. For some reason, I suspect that the “My Vault” folder either has reached its limitation to add more files, or the .dat files were corrupted, or the program looked for specific numbers of files before opening the “My Vault” file. Instead, I put both files on the root directory and finally I reached the password prompt, which I was able to gain access to my files again! Please note that there is an upgrade to version 3 — “SanDiskSecureAccessV3_win” — and be sure to follow the procedure, as outlined, in titled, “Migrating from SecureAccess 2.0 to SecureAccess 3.0 on a PC”.

   I was able to do that with success. I know how frustrating the whole process becomes until you do the right steps. Remember to make an extra copy of your .dat files to another folder so that you can retain your original files to avoid from corruption. As long as you have the listed files similar to mine and many .dat files with reported file size above zero, you should be able to succeed. Otherwise, your data is corrupted and/or lost.

Best of luck.      

Hello Judo, thanks for your tuto ! :wink:

I need your help when you said : “First. run the backup function from the Tools menu within “My Vault” before you do anything else. Second, you only need to save SanDiskSecureAccess Vault (File folder) to your PC/MAC.  Otherwise, here is what I endured until I finally got access to my encrypted .dat files again.

I don’t have to open “SanDiskSecureAccess Vault” and i just do a right click on the icone and click to “send to” and “Desktop” ?

No. If you are able double-click on “SanDiskSecureAccessV2_win” application, which prompts for a password, to access “My Vault” with the saved password, then if you want to save a backup copy for your files, then go to Tools | Backup Data.

Please note that in version 2, there are two locations on Windows PC that could hold a backup copy: Users | Your Username | AppData | Local | SanDiskSecureAccessV2_win folder or My Documents, whichever location you chose to store.

Now the Vault file is a placeholder of all your encrypted .dat files and System Files folder, which you only need rifht-click on the file to send to “My Documents” or “Desktop” to make a copy. Do not use the cut and paste function because the computer could crash or USB could disconnect for any reason.

I hope this answers your question.

Best regards…


Hello Judo, thank again for your answer.

I have saved my .dat files in my computer, i have format my drive, i have reinstall Sandisk SecureAccess 2.0 on my drive, with the same password, but now when i copy and paste a .dat file from my computer to the Vault folder, nothing appears when i log in “SanDiskSecureAccessV2_win” :cry:

I have forget something ? :confounded:

Some clarifications :

  • The files i copied in my computer (i have an icon on my desktop) are registred to Alexandre - AppData - Roaming - Encrypstick - Backup.

  • I don’t have the icon with the safebox (like the original SanDiskSecureAccess Vault), just a folder icon.

  • In this folder, i have a file “backup.enc” 1KB

If it helps…

Look at the file size of each .dat files in your folder. The greater the number of .dat files that you have within a folder with greater than 1 KB, then you have something to work with to copy the files onto the USB drive, as I outlined in the original post.

Since you have backup.enc with only 1 KB, then that would not be the correct file. The Vault file must be named “SanDiskSecureAccess Vault” for it to work. Case-in-point, when I right-click to “Properties” on a Vault file, I have 5.77 GB. Each .dat file has 1 KB upwards to 40,000 KB. In that folder, I have approximately 13,000 files. So if you have something in your Vault folder, then you should be able to access your files with the correct password that you KNOW. I cannot help anyone to gain access to an encrypted .dat files that does not belong to the person trying to gain access. Hence, the purpose of encryption.

Anyway, I renamed my backup folder as “SanDiskSecureAccess Vault_ORIG” so that I knew that the contents were original when I cut and pasted the folder to my desktop. I explained the steps in my original post as the best that I could.

Best of luck!

Yes Judo thanks for your help. You get involved more to help us than sandisk support team…

That’s my files I’m trying to decrypt those of someone else. I tried to do as you say but I can be misunderstood (i’m not english)

Now i have format the drive, i still have the files, but it’s maybe damned if I have not done as it should (for example for the 1KB backup.enc file or my saved folder whose named 4C530001150325119542 and not SanDiskSecureAccess Vault). In any case, thank you for helping

Hello, I seem to have a very similiar situation with my sandisk cruzer flashdrive. All of my files are in a Dat format. I do not understand how this had happened. The files were originally in the vault. I know the password to the vault but now when i access it there are no files saved inside. i have contacted sandisk multiple times about this issue. They tell me the files are corrupted. however i do not believe that they are. The files are taking up space on the flashdrive and i did nothing for them to become corrupt. Please help me these are important files that i need. 

i did nothing for them to become corrupt.

Did the machine the drive was plugged into loose power while the drive was still plugged in?

Did you remove the drive from the machine without using the Windows Safe Removal option?

Did you reboot the machine while the drive was still plugged in?

Some of the things that can cause corrupt a drive.  Try running a CHKDSK command on the drive and see if it finds errors.

Im working with a Mac, not a Pc. None of these instances had occured. I believe they are not corrupt because i have taken the drive to Geek squad and they had put the drive into their computers. They told me they had been able to see the files in JPEG and movie formats. Which my files are of photos and videos. They could not open or view them because of securty reasons. I need to find a way to conver the Dat fiels into their orginal files.

They could not open or view them because of securty reasons. I need to find a way to conver the Dat fiels into their orginal files.

Did you refer the Geek Squad people to this thread?  It describes a process how to recover .dat files.

I have been wondering what to do about this problem!  I thought I knew the password for my thumb drive, but when it wouldn’t let me in, I didn’t know what to do!  By the time I found the answer (which is now on the San Disk website), I had already given myself a new password for my profile on my PC.  Now, I’m actually worried about loading up my old vault which would be 3 years old and from an old hard drive.  Should I just get myself some new credentials and start over?  I sure will I Had foun your solution earlier.  I had one long night of complete panic