SanDisk Ultra 2.0 USB 32 GB Drive: RESOLVED to Open Original Vault File Except for Another Drive

Initally, I was not able to add more files to the SecureAcces Vault on my new SanDisk Ultra 3.0 USB drive. After my research, deponia and others someone suggested to move the files to the Windows PC and reformat the USB drive as ezFAT, which helps to overcome the 4GB max with FAT32—*see original post location at the bottom.

WORD OF CAUTION: Before you UPGRADE, follow the steps outlined in “Migrating from SecureAccess 2.0 to SecureAccess 3.0 on a PC,” which I missed because of the original post location (*bottom).

Having done that, I attempted to move the original files, three folders and one application, back on to the Sandisk USB drive. I received an error stating that there is not enough space and requires 388 GB—yes, 388GB! Then it dawned on me that might be the reason that I was not able to add more files to the USB drive. However, the “Computer | USB Drive Letter” property information indicated that there is 10 GB used out of 29.8 GB.

According to original “SanDiskSecureAccess Vault” folder properties shows 0.99 GB file size. I can see many .dat files outside of the System folder. I would prefer to have the correct method to access the original encrypted files without corrupting the original files. Instead, I just copied the Vault folder that includes the System Files folder to the drive after reformatting the drive.

Clicked on “SanDiskSecureAccessV2_win” app from the Windows Desktop folder,—note that I transferred all files and app into the Windows PC desktop folder—the program automatically started to download the new update to “SanDiskSecureAccessV3_win”, which I stopped to avoid corrupting the original vault data files since it asks for a new password to a new file, which I had already done on the new USB drive itself.

It would have been nice to use the same app to open a different vault file.

Originally, I had not backed up the drive under the assumption that moving the files from the USB drive to the Windows PC would not corrupt the files.

Having said that, I used another SanDisk Cruzer 32 GB drive, ran the backup function of my existing files just to see the location of the new backup file—stored at SanDiskSecureAccess Vault | System Files | as USB Flash Drive-xxxxxxxxxxxxxxxxxxxx.idx and USB Flash Drive-xxxxxxxxxxxxxxxxxxxx.idx.bak. Replaced the x values from characters and numbers for security reasons. It is interesting that the backup file is stored in the same main vault folder. Also you can see two different files that has the same encryption key code in order for the program and files to work.

To test my theory, with the Internet connection disabled, I renamed “SanDiskSecureAccess Vault” to “SanDiskSecureAccess Vault—BAK”, copied the original file from the Windows PC Desktop folder, which is “SanDiskSecureAccess Vault” onto the USB drive and ran the SanDiskSecureAccessV2_win program. It started to ask for a new password, which meant that it is in the process of creating a new vault file. I closed the program. I renamed the “SanDiskSecureAccess Vault” file to “SanDiskSecureAccess Vault—ORIG” and reverted the original BAK file to “SanDiskSecureAccess Vault,” which does not work anymore. Bottom line, in a programming sense, is that the pointer to the original vault file no longer works. What did I miss here?

Last attempt, I ran the SanDiskSecureAccessV2_win program, created a new password—used the same original password—, added one folder and a mock file, and closed the program. I still kept the “SanDiskSecureAccess Vault—BAK” file on the USB drive. I accessed the new System folder, deleted all 6 files, and copied and pasted all files from the “…Vault—BAK” System folder. I ran the program again and VOILA, the folders and files appeared. I was able to move the file/folder to the Windows PC. Now that was just a small part from the old Cruzer USB drive.

Finally, now that my theory is correct, I repeated the same steps (above) except the files came from the “SanDiskSecureAccess Vault—ORIG” folder that has 1 GB of files. I ran the program once again and it did not work because the files originated on another drive. I reverted back to the recent files in the System Files folder and it is OK.

With the Ultra 32 GB drive, I reformatted the drive back to FAT32, copied the Vault files without the software, and reinstalled “SanDiskSecureAccessV2_win” program because it was the original program that created the Vault files. I repeated the same steps, in the former, and I was not able to gain access to the encrypted files, as the program kept asking for new password.

I read the suggestions, after the fact, and repeated all the steps again from another post that did not work for me. It just seems to be in an infinite loop without any success to gain into my encrypted files. The physical file size remains unchanged. It would be nice for SanDisk to provide a workaround on the Windows drive instead of the USB drive to gain access to the encrypted files with the right password, which I already had about a week ago. I did note the file name that refers to to the USB drive that are different between both USB devices—Cruzer Glide and Ultra. I can save and delete a file outside of the Vault with no problems. I even unchecked “Read Only” of the Vault file that did not work.

I will continue to work on the drive until I find a solution. Please note that version 3 has different file format and structure than version 2 so I have to continue with version 2 until I am able to gain access to the encrypted files, run a backup copy, and save the decrypted files to the Windows PC drive. Then I can proceed with version 3 upgrade.

Any other suggestion, other than Albert’s initial suggestions, will be greatly appreciated. He kept saying no problem or no worries. The whole process and time has gone beyond what I had ever experienced with an encrypted drive and files. I do not blame the software/program due to the Windows’ file limitation. The solutions offered to many users’ complaints has not resolved my problem, yet.

Original post: problem transferring files to a SanDisk Cruzer Fit USB
Replied by Deponia dated 02-16-2015 03:43 AM

See my post " RESOLVED: SecureAccess 2.0 Windows—Able to open .dat Files" — Sweet!